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This chapter discusses the 

latest version of Microsoft 

Office, with its ribbon style 

of user interface. It identifies 

the range of editions, and 

outlines the requirements 

for installation. Also covered 

are the process of starting 

applications, features such 

as Preview and Save, used 

by all Office applications, 

Office document types and 

compatibility with the older 

versions of applications.
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Microsoft Office 2010

New PCs may come 
with Office 2010 Starter 
edition, which contains 
Lite versions of Word 
and Excel. There are 
also Standard and 
Professional Plus editions 
for businesses, but these 
are not available in retail 
packages. See page 
220 for details of all the 
editions of Office 2010. 

Microsoft Office is a productivity suite of applications that share 
common features and approaches. There have been numerous 
versions, including Office 95, Office 97, Office 2000, Office XP 
(also called Office 2002), Office 2003 and Office 2007. The latest 
version, released in June 2010, is Microsoft Office 2010.

There are various editions, with particular combinations of 
applications. The Home and Student edition contains:

• Excel 2010   Spreadsheet and data manager

• PowerPoint 2010  Presentations and slide shows

• OneNote 2010  For taking notes

• Word 2010   Text editor and word processor

• Office Tools  Diagnostics and image utilities

The Home and Business edition of Office contains all of the 
applications in the Home and Student edition, plus:

• Outlook 2010  Electronic mail and diary

The Professional edition of Office contains all that found in 
Home and Business edition, plus two additional applications:

• Access 2010  Database manager

• Publisher 2010  Professional document creation

There’s also a Professional Academic edition, which contains the 
same applications as the Professional edition, but at a preferred 
price for qualified users. 

To illustrate the relative costs for these editions, recommended 
prices in the USA (and the numbers of licenses included) are:

 Edition   Boxed  Key Card
 Home and Student $149 (3) $119 (1)
 Home and Business $279 (2) $199 (1) 
 Professional  $499 (2) $349 (1) 
 Professional Academic $ 99 (2)  n/a 

If you run 64-bit Windows 7 or Windows Vista, there is a 64-bit 
version of Office 2010 available. However, you should still run the 
32-bit version, unless you have very large Excel spreadsheets. 

There’s no upgrade 
pricing for Office 2010 
editions, but there is a 
key card price for pre-
installed or downloaded 
copies. This is for a single 
PC only, unlike the boxed 
editions, which include 
2 licenses (or 3 for the 
Home and Student). 
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The Ribbon based user interface 
also features extended ScreenTips 
that can contain images and links to 
more help, as well as text. The tips 
are displayed when you move the 
mouse pointer over a command, they 
describe what the commands do, and 
give keyboard shortcuts. 

This result-oriented 
user interface was first 
introduced in Office 
2007, and now appears 
in all the applications in 
Office 2010. 

You can rename and 
change the order of the 
default tabs and groups, 
and you can create 
your own custom tabs 
and add groups to the 
ribbon. See page 44 for 
an example. 

Whichever edition you have, the most notable feature of Office 
2010 is the graphical user interface based on the Ribbon. This 
replaces the menus and toolbars that were the essence of previous 
versions of Office.

The Ribbon contains command buttons and icons, organized in a 
set of tabs, each containing groups of commands associated with 
specific functions. The purpose is to make the relevant features 
more intuitive, and more readily available. This allows you to 
concentrate on the tasks you want to perform rather than the 
details of how you will carry out the activities.

Some tabs appear only when certain objects are selected. These are 
known as contextual tabs and provide functions that are specific 
to the selected object. For example, when you select an inserted 
image, the Picture Tools Format tab and its groups are displayed.

:

Ribbon Technology
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What’s Needed

The requirements are the 
same as for Office 2007. 
Note that your operating 
system may require a 
minimum level of update, 
denoted by the SP 
(Service Pack) number. 

The illustrations in this 
book are usually based 
on Office Professional 
Plus edition, running 
under Windows 7 
Ultimate. However, the 
tasks shown generally 
apply to any edition or 
operating environment.

These are the minimum 
requirements. A higher-
speed processor, with 
additional memory, is the 
preferred configuration.

To use Microsoft Office 2010, you will need at least the following 
components in your computer:

• 500 MHz processor

• 256 MB memory

• 3.0 GB available disk space

• CD-ROM or DVD drive

• 1024×768 resolution monitor

• Windows 7, Windows Vista (+SP1), or Windows XP (+SP2)

Some functions impose more stringent requirements, for example:

• 512 MB memory for Outlook Instant Search

• 1.0 GB memory for Word grammar and contextual spelling

• Internet connection for online help

If your computer is running Windows 7, you’ll find that the 
system specifications already meet or exceed requirements for 
Office 2010. You’ll also find that the Office 2010 user interface 
coordinates well with the visual style of Windows 7 and Aero. 
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If you’ve purchased a new copy of Office 2010, you will need to 
install it onto your computer. Insert the supplied CD or DVD, 
enter the 25 character product key, and accept the terms and 
conditions. Follow the prompts to complete the installation.

l1 Select Install Now to accept the default settings

If you have an older 
version of Office, you 
may be offered the 
option to upgrade the 
existing installation.

Click the Microsoft Office 
entry and select Run all 
from My Computer, to 
install extras for all of the 
components.

Installing Office 2010

l2 Select Customize to choose how items are installed, 
then click a component and choose Run all from My 
Computer to include all the extras for that item 

l3 Select Not Available to exclude the selected component
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Start an Application

This shows Windows 7. 
However, the same 
shortcuts are added to 
the Windows Vista or the 
Windows XP Start Menu.

Activating an application 
in Office activates all the 
other applications in the 
suite at the same time.

If you choose not to 
activate immediately, 
you can run the software 
for a period of 30 days, 
before it makes features 
unavailable.

When you have installed Office 2010, a new folder of shortcuts 
will be added to the Start Menu.

l1 Select Start, All Programs

l2 Select Microsoft Office 
to display all the installed 
applications

l3 Select Microsoft Office 
Tools to display the 
various utilities

l4 Select the application 
that you wish to run, for 
example Word 2010

When you start any Office application, you are reminded that you 
must activate your installation to fully enable all the features.

l5 You can activate your copy of Office 2010 over the 
Internet or by telephone
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The Application Window
When you start an Office application, such as Excel, PowerPoint 
or Word, the program window is displayed with a blank document 
named Book1, Presentation1, or Document1, respectively. Using 
Word as an example, the parts of the application window include:

BackStage  Quick Access toolbar   Document name   Tabs
(File tab)

Status bar     Scroll bars            View buttons            Zoom level

Applications like Access and Publisher don’t open a blank 
document, but open in the BackStage view instead and offer a 
set of predefined layouts. For Publisher, these include brochures, 
business cards, calendars and labels, as well as blank documents.

Minimize/Restore/Close

Help button

Ribbon

Commands and icons 
(display lists or galleries)

Launch button
(shows dialog box)

File commands         Publication types           Document templates

Tabs

Blank documents

The Ribbon is hidden in 
the Backstage view in all 
Office 2010 applications. 
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Live Preview
With the Ribbon interface, you can see the full effect of 
formatting options on your document, such as fonts and styles, by 
simply pointing to the proposed change. For example, to see font 
formatting changes:

l1 Highlight the text that you may wish to change, then 
select the Home tab

In previous versions, 
you would be shown a 
preview of the new font 
or style using a small 
amount of sample text.

The selected text is 
temporarily altered 
to show the font (or 
the font size, color or 
highlight) you point to.

l2 Click the arrow next to the Font box and move the 
mouse pointer over the fonts you’d like to preview

l3 Click the font you want to actually apply the change to 
the text, or press Escape to finish viewing font options

l4 Similarly, you can preview the alternatives 
provided for the Font Size, the Font Color, 
and the Text Highlight Color options
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…cont’d

Live Preview is available for paragraph format options (e.g. bullets, 
numbering, and shading) and for styles.

l1 Highlight the text that you may wish to change, then 
select the Home tab

l2 Display the list of paragraph options, and move the 
mouse pointer over any that you want to preview

l3 Display the list of styles (with no text selected) and 
preview the complete document in a variety of styles

The option will be 
previewed for the 
paragraph where the 
pointer is currently 
located, if no text has 
been selected.

This facility is not 
available in Excel, which 
does not offer the 
Paragraph group.

You can turn off Live 
Preview for individual 
applications. Click the File 
tab, select the application 
Options command, click 
General, and then clear 
the Enable Live Preview 
box.
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You’ll use the appropriate commands on the Ribbon for each 
application, to create and amend the application document. You 
should save the document periodically, to avoid the possibility of 
losing the work you’ve done.

Save the Document

See page 26 for an 
example of creating a 
Word document, and 
page 70 for an Excel 
workbook.

A name, such as Book1 
or Document1, assigned 
to a blank document is 
a temporary name, so a 
permanent name must 
be provided when the 
document is first saved.

l1 Click the File tab 
and select Save

l2 For a document 
not yet named and 
saved, the Save As 
dialog opens so 
you can provide a 
name (or use the 
suggested name)

l3 On subsequent Saves, the document will then be written 
to disk without any further action needed

l4 To save the document under a new name, select the File 
tab, and then select Save As 
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The Ribbon takes up a significant amount of the window space, 
especially when you have a lower-resolution display. To hide it:

l1 Click Minimize the Ribbon, 
or Right-click the tab bar and 
select Minimize the Ribbon

l2 The File tab, Quick Access 
toolbar, and tab bar will still be 
displayed while the Ribbon is minimized

When the application 
window is reduced below 
a certain width or depth, 
the Ribbon may get 
automatically hidden, 
along with the tabs row 
and the Quick Access bar.

Hold down the Alt key 
and press the keys in 
sequence, for a two-letter 
shortcut, such as PW 
(Watermark), press Esc to 
go back up a level.

Working With the Ribbon

l3 The Ribbon reappears temporarily when you click one of 
the tabs, so you can select the required command

l4 Alternatively, press and release the Alt key to display 
keyboard shortcuts for the tabs

l5 Press Alt + shortcut key, for example Alt+P, to select Page 
Layout, and display the Ribbon and shortcuts for that tab

Repeat step 1 to redisplay 
the Ribbon continuously.
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Quick Access Toolbar

The Save As dialog will 
open the first time you 
click Save for a new 
document (see page 30).

You can click the File tab, 
then click the application 
Options and select Quick 
Access Toolbar to display 
this dialog.

The Quick Access toolbar contains a set of commands that are 
independent of the selected tab. There are four buttons initially:

                       Save         Undo         Redo         Customize 

l1 Click the Save button to write the current contents of the 
application document to the disk drive

l2 Click Undo to reverse the last action, click 
Redo to re-apply, and click the arrow to 
select several actions to undo

l3 Click the Customize button to add or 
remove icons, using the list of popular 
commands

l4 Click More Commands to display the 
full list of commands, then add and 
remove entries as desired

You can right-click any 
command on the Ribbon 
and select Add to Quick 
Access Toolbar.
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The objects you create using the Office applications will be office 
documents of various types, including:

• Formatted text and graphics Word document

• Flyers and brochures  Publisher publication

• Spreadsheets and data lists  Excel worksheet

• Presentations and slide shows PowerPoint presentation

Each item will be a separate file. By default, these will be saved in 
the Documents library for your username (logon ID).

l1 To show the entries currently stored in your folder, click 
Start and select Documents from the list

Office Document Types

l2 Click the Views button and choose 
Details, to show the file information, 
including date modified, size, and type

Note that, in some applications, groups of related items will be 
stored together in a specially structured file. For example:

• Data tables, queries and reports Access database

• Messages, contacts and tasks Outlook folders

• Notes and reminders  OneNote folders

The Documents 
library consists of the 
Documents folder for 
the current user, and 
the Public (shared) 
Documents folder. 

You can specify a 
different folder, or 
subfolder, for particular 
sets of documents.
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File Extensions
To see the file extensions associated with these document types:

l1 Click the Organize button, then select 
Folder and search options

l2 Click the View tab

l3 Search through the list 
of Advanced settings to 
locate and clear the box 
for ‘‘Hide extensions 
for known file types”

l4 Click OK to apply the 
change to all folders

l5 The file type will be 
shown, along with the 
file name, whichever 
folder view you choose

Files saved in Office 2010 
use OpenXML formats 
and extensions, for 
example .docx and .xlsx. 

You can also find Folder 
Options in the Control 
Panel, under Appearance 
and Personalization. 
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Office 2010 will open documents created in previous versions of 
Office applications, for example .doc (Word) or .xls (Excel).

l1 Click the File tab and select Open, then click the down 
arrow for document type to list the types supported

Compatibility Mode

l2 Choose the document type, 
Word 97–2003 for example, 
then select the specific name

l3 Documents created in previous versions (including .docx 
files from Word 2007) are opened in Compatibility Mode

You may need to 
save documents in 
Compatibility Mode, as 
those you wish to share 
files with may not have 
Office 2010.

Compatibility Mode 
prevents the use of new 
or enhanced features, 
so the documents 
can continue to be 
used by systems with 
older versions of the  
applications.

Compatibility Mode 
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You can also click the 
File tab, select Save As, 
and choose the standard 
Office format (e.g. Word 
Document) to carry out 
the conversion.

With Save As, you have 
the option to change 
the file name, and the 
location for the new 
document. 

Step 3 will create a file 
of the same name, but 
with the new Office 
2010 format extension. 
The original file will be 
deleted.

If you have opened a document in Compatibility Mode, you can 
convert it to the standard Office 2010 format.

l1 Select the File tab button and click the Convert button

Convert to Office 2010

l2 Click OK to confirm that you want to convert the 
document, and the compatibility restriction will be 
removed

l3 To replace the original file, select File and then Save, or 
click the Save button on the Quick Access toolbar

l4 To retain the original while creating a new file in Office 
2010 format, select File, then Save As, and then click Save 
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Save your Office 2010 document online, in the Windows Live 
SkyDrive, a central location where you and others can view and 
edit documents in the browser. To save the document 

l1 Open the document in the Office 2010 application
You can save Word, Excel, 
PowerPoint, and OneNote 
documents in SkyDrive, 
and access them using 
Office Web Apps (see 
page 228 for details). 

Save to Web

l2 Select the File tab, and, in the BackStage view, click Save 
& Send and then click Save to Web 

If you use Hotmail, 
Messenger, or Xbox 
Live, you already have a 
Windows Live ID. If you 
don’t have one, click 
Sign up to create a new 
Windows Live ID.

l3 Click Sign In, enter your 
Windows Live ID (email 
address) and your password, 
and then click OK 
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Click New Folder to 
create a folder on 
SkyDrive, for your use or 
to share with others. 

…cont’d

l4 Select a Windows Live SkyDrive folder and click Save As

l5 Type a name for your file and click Save.

l6 Visit skydrive.live.com to view your files and folders. 

Using SkyDrive, you can 
send a link rather than 
an attachment, and 
maintain a single copy of 
the document that others 
can view and update. 
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