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Zooming in and out
Work for a day in Photoshop and you’ll find yourself zooming 
in and out on your images constantly. As with all design tasks, to 
become faster and to be efficient you should look to identify those 
tasks that you perform on a regular basis and find the quickest, 
most efficient and effective way to perform them. Zooming in and 
out provides one of these opportunities.

Instead of moving your cursor to the Zoom tool, clicking on it to 
select it, then moving your cursor back into the image to perform 
the zoom in/zoom out, and then going back to the Tool panel to 
either re-select the tool you were previously working with or select 
a different tool – try using the keyboard/mouse shortcut below.

l1 Working with any tool other than the Zoom tool, hold 
down cmd/ctrl and the Spacebar to temporarily access the 
Zoom tool.

l2 Drag diagonally down and to the right to zoom in, or 
diagonally up and to the left to zoom out.

l3 When you release the cmd/ctrl keys and Spacebar you can 
continue working with the tool that you were previously 
working with.

If you are 
working on a 
Mac, make sure 
you hold down 
Spacebar 

slightly before the cmd key. 
If you hold down cmd first, 
the Spotlight Search entry 
field appears; although the 
zoom technique still works:

Don’t use this 
keyboard 
shortcut if you 
have the Text 
Insertion Point 

flashing in text as there is a 
danger, when using the 
Spacebar as part of the 
shortcut, that you will 
accidentally introduce 
unwanted spaces in  
the text.

Another good 
reason for 
learning this 
shortcut is that 
you can use the 

same technique in Adobe 
InDesign and Illustrator.
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Content-Aware crop
Content-Aware crop is useful when you want 
to retain as much image detail along the corner 
edges of an image when you need to rotate 
and straighten it and/or expand the Photoshop 
canvas area beyond its initial size. The Content-
Aware technology fills areas that would 
otherwise be lost, to create a seamless result 
based on existing pixel data in the image.

l1 As an optional first step, choose View 
> Rulers, to show the rulers along the 
top and left edges of the image window. 
Position your cursor in the top ruler, 
then drag in a ruler guide to act as an 
additional visual reference if required.

l2 Select the Crop tool and 
create the crop. Position 
your cursor slightly outside 
the crop bounding box. The Rotate 
cursor appears (   ). Drag in a circular 
direction to rotate the crop bounding 
box. Without the Content-Aware 
crop checkbox selected, Photoshop 
automatically resizes the image to 
accommodate the rotated pixels. Pixels 
outside the crop bounding box are lost 
if you accept the crop.

l3 When you select 
the Content-
Aware checkbox 
in the Options 
bar, the crop rectangle expands to the 
size of the entire image. Areas of the 
image along the corners are filled with 
image detail generated by Photoshop’s 
Content-Aware technology.
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Perspective crop
Here’s a quick fix for converging verticals – the keystone effect 
you can get with some images, often most noticeable in images 
consisting of architectural detail and especially tall buildings.

l1 Open the image. Make sure your 
rulers are showing. Choose View 
> Rulers to show rulers along the 
top and left edge of the image 
window if necessary. Position your 
cursor in the ruler on the left, then 
drag in one or more vertical ruler 
guides so that you can evaluate 
the image and gauge the degree 
of convergence that you need to 
eliminate.

l2 Select the Perspective Crop tool from the 
Crop Tool group. Make sure Show Grid 
is selected in the Options bar. Proceed to 
define a perspective crop grid – in this case 
to straighten the verticals and get rid of 
the keystone effect currently visible on the 
building’s facade.

l3 In this example, click in the top-left corner 
of the facade inside the top corner of the 
leftmost column. This sets the first corner of 
the perspective grid correction.

l4 Reposition the mouse (do not press and drag 
the mouse button) – just move it downward 
to define what should be a vertical. In this 
example, down towards the bottom-left of the 
corner image at the base of the pillar.

l5 Click to set the first vertical. Again reposition 
the mouse – do not press and drag the mouse 
button – to define the bottom edge. Notice,  
as you do so, that the perspective grid starts  
to form.
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l6 Click to set the third corner of the 
perspective grid (using the vertical ruler 
guide as an aid to positioning the click). 

l7 Again move the cursor to create the 
final anchor point for the perspective 
grid. Click. The perspective grid now 
displays bounding box handles that  
you can adjust to finalize the 
perspective crop.

l8 Use the center bounding box handles 
(top, bottom, left and right) to expand 
or contract the overall size of the 
perspective grid crop area. Avoid using 
the corner handles unless absolutely 
necessary, as you may introduce 
distortion into the resultant crop.

l9 Click the Commit button when you 
are ready. Reposition the original 
ruler guides as required to check 
the accuracy of the correction to the 
verticals in the image.

...cont’d
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Reset Preference Settings
Macs and PCs, Mac and Windows operating systems, and 
applications like Adobe Photoshop, have come a long way over 
the last 25 years or so. All aspects of the personal computer  
technological revolution are now far more reliable than they were 
in the early days of the desktop computer revolution. But, even 
so, “things” on a computer can get a bit muddled and mixed up, 
and start to go awry for any number of reasons. If you experience 
erratic behavior in Photoshop – on those rare occasions, and they 
are rare – one of the first troubleshooting steps you can take is 
to reset the Preferences Settings file. Resetting the Preferences  
Settings file is sometimes all you need to get Photoshop running 
smoothly again.

Photoshop loads the Preferences Settings file every time you 
launch the application. Resetting the Preferences Settings often 
simply clears some minor corruption to the Preferences file that is 
causing the slightly erratic behavior. Resetting removes the old file 
and re-creates a fresh, new file.

l1 To reset Photoshop Preferences, click the Photoshop icon 
either in the Taskbar/Start menu (Win) or the Dock/
Applications folder (Mac). Immediately after you do 
this, hold down ctrl/cmd + Alt/option + Shift keys. Be 
prepared to hold down the keys as soon as you’ve clicked 
to launch the application – it’s easy to just miss the 
opportunity (in which case you’ll need to quit Photoshop, 
then try again).

l2 Keep the three keys 
held down. After 
a few seconds the 
Delete Settings File 
warning appears. 
Click OK to reset 
the Photoshop 
Preferences Settings file.

l3 Photoshop continues to launch, and recreates a new 
Preferences file using default settings. Notice, among 
other things, that the Start screen no longer displays your 

If you get 
persistent 
technical 
problems using 
Photoshop, the 

cause is probably not 
Photoshop itself, but some 
other underlying operating 
system issue for which you 
might need to seek 
professional help to solve.
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most recent documents, and that all custom tool settings 
have been returned to their original default settings. 
On the other hand, for example, custom colors in the 
Swatches panel are not lost as these are not saved as part 
of the Photoshop Settings file.

Manually removing the Photoshop Settings file

l1 Make sure that Photoshop is not running. From your 
Mac or Windows Desktop, navigate to the Adobe 
Photoshop Settings file (Prefs.psp).

...cont’d

l2 Move this to a different location. It’s 
worth moving it rather than deleting it, so that you have 
a copy of the Settings file that might be helpful if further 
detailed troubleshooting is required.

l3 Launch Photoshop. On launch, Photoshop generates a 
fresh default Settings file – at the same location as the 
Settings file you just removed.

Windows location:

Mac location:
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Brushes figure prominently whatever kind of work you do in 
Photoshop – not just when you apply color, but also when making 
and refining selections and masks, and removing unwanted detail, 
as well as dodging and burning areas of detail. Master these 
shortcuts to master your brushes.

Brush size

l1 To increase/decrease the size of your brush in increments 
without having to first access one of the Brush panels, 
simply press the square bracket keys on your keyboard:

Controlling brushes

]
Increase

[
Decrease

l2 Use the following keyboard and mouse combination to 
increase/decrease the brush size interactively. This gives 
you quick visual control over the size of your brush, and 
it is well worth practicing a few times so that you fully 
master the technique. Hold down the Alt key (Win), ctrl 
+ Alt/option (Mac). Press and drag left or right using the 
mouse button:

Hardness/softness
Soft edge brushes fade along the edges, creating a semi-
transparent effect. Hard edge brushes produce a more clearly 
defined, opaque edge.

Decrease Diameter Increase Diameter

There are some 
instances where 
the precise 
position of the 
brush or editing 

tool is more important than 
the size of the brush. Press 
the Caps Lock key to convert 
the cursor to a precise, 
crosshair cursor. Remember 
to press Caps Lock again 
when you no longer need 
the crosshair cursor.

+ drag right mouse 
button left or right

Win

+ drag mouse button 
left or right

+

Mac
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l2 You can also use an on-screen 
mouse/keyboard combination. 
Hold down the Alt key 
(Win), ctrl + Alt/option 
(Mac). Press and drag up or 
down using the mouse button:

Opacity
Opacity controls how transparent or 
see-through the color is as you apply 
it. Use the number keys along the top of the keyboard, not on 
the Numeric keypad, to change Opacity levels. Values of less than 
100% will allow image content on layers below to show through 
the paint.

l1 To change the Opacity, with the Brush tool selected, type 
1 to change opacity to 10%, 2 to change to 20%, 0 to 
change to 100%. Type 47, for example, to change opacity 
to 47%.

l1 To increase/decrease the hardness of a brush using the 
keyboard, use the following keyboard shortcut:

]

Increase

[

Decrease

+ +or

Angle and roundness
To quickly change settings for the angle 
and roundness of the brush, right-click 
(Win)/ctrl + click (Mac) to access the 
on-screen Brush Presets picker panel. 
Drag the dots on the brush shape 
thumbnail, in the top-left corner, to 
change the roundness. Drag the arrow 
tip in a circular direction to change the 
angle of the brush.

These 
techniques also 
apply to 
editing tools 
such as the 

Blur, Sharpen and Smudge 
tools, the Dodge, Burn and 
Sponge group, and the 
Eraser tool.

...cont’d

+ drag mouse 
button up or down

+

Mac

Increase hardness

Decrease hardness

+ drag right mouse 
button up or down

Win
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Pixel Grid
The “Pixel Grid” is a non-printing 1-pixel overlay. This can be 
really useful if you are working with web graphics where being 
pixel-perfect is essential, or in other situations where precision 
is important. Equally, there can be times when the Pixel Grid is 
visually intrusive and distracting. You need to be able to switch it 
on and off as circumstances demand.

When the option is switched on, the Pixel Grid appears 
automatically when magnification goes above 500%, and 
disappears when magnification goes below that value.

The following example shows how useful the Pixel Grid can be 
for cropping an image with absolute precision.

l1 To switch the Pixel Grid off/on, choose View > Show 
> Pixel Grid. A checkmark next to the option indicates 
that the option is on; the option is off if there is no 
checkmark.

Pixel Grid Off

Pixel Grid On

If you do a lot 
of work with 
web graphics it 
can be useful 
to set up a 

custom keyboard shortcut 
to switch the Pixel Grid on 
and off quickly. See pages 
28-30 for instructions on 
how to set up your own 
keyboard shortcuts.

You can use 
the keyboard 
shortcut ctrl/
cmd + H to 
Hide/Show 

“Extras”. Extras are the 
commands available in the 
View > Show sub-menu. 
Pixel Grid is one of these 
commands, so you can use 
this keyboard shortcut to 
hide and show the Pixel 
Grid. The downside is that 
this is a global shortcut and 
hides other elements such 
as Ruler Guides and Smart 
Guides that you might want 
to keep active.
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Recent Files panel
It’s amazing how Photoshop projects get complex quickly. And 
many Photoshop users work on more than one project at a time. 
When you are working with projects involving large numbers of 
images and complex series’ of graphics, it’s surprising how much 
time you can waste just finding the exact image you want to open.

Seeing thumbnails is probably one of the most effective ways to 
identify the exact image you want to work with, especially when 
there are a number of very similar variations of the same file.

The Photoshop Start workspace gives you 
the option of viewing thumbnails, but if 
you choose File > Open Recent, when 
you are already working in Photoshop, 
you get a list of filenames that are not 
necessarily helpful when it comes to 
selecting exactly the right file. How many 
times have you opened up an image only 
to mutter a silent curse under your breath 
– “No, not that one!” Unfortunately, the 
Open Recent list doesn’t give you the 
option of seeing thumbnails – which can 
often make for a much quicker visual 
recognition, identification and selection.

If you want to identify, recognize and 
select accurately the first time, use the 
Recent Files panel.

l1 To show the Recent Files panel so that you 
can identify and open files visually, choose 
Window > Extensions > Recent Files.

l2 Make sure that the 
Thumbnails View button is 
selected.

l3 Scroll through the Recent Files thumbnails. 
Click once on a thumbnail to open the file.

The Recent Files 
command does 
not have a 
default 
keyboard 

shortcut. It’s well worth 
setting one up. (See pages 
28-30 for further 
information.)
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Notes
Some people have 20/20 vision; some have 100% recall. If you’re 
one of those, you probably don’t need this tip – skip it and move 
on. If you are more ordinary and lead a busy life, the Notes panel 
could save you considerable amounts of scarce production or 
creative time, and a lot of potential frustration. The idea is simple 
– the Notes panel can provide an effective, easily managed aide-
memoire to some of the complex settings that you might use only 
occasionally.

You can also use it for handover purposes. If another team 
member needs to work on the file and follow certain guidelines 
or instructions, rather than sending a separate email that might 
get lost or deleted by the time it’s needed, use the Notes panel 
to embed any crucial image-related information in the file – that 
way, instructions, warnings and guidelines travel with the file and 
should never get lost.

l1 To create a note, select the Note tool – found in the 
Eyedropper tool group.

l2 Position your cursor on the 
image. Click to show the 
Notes panel where you can 
write your note. An active 
Note icon appears where 
you click. Enter the text 
for the note in the Notes entry box.

l3 Click on the Note icon to make the 
note active and display the content 
of the note in the Notes panel. The 
pencil on the Note icon indicates 
that the note is active. Click on an 
active note to deactivate it and hide 
the content of the note in the Notes 
panel. The Note icon no longer displays the pencil.

l4 To delete the active note from the Notes panel, click the 
Trash button (   ) at the bottom of the panel.  

You can 
position your 
cursor on a 
Note icon, then 
drag it to a 

new position. You can also 
position the note outside 
the canvas area if required.

You can have 
multiple notes 
in a document. 
Click the 
Previous/Next 

arrows (  ) in the Notes 
panel to cycle through the 
notes. Alternatively, you 
can click on any Note icon, 
using any tool, to select 
that specific note.

You can also 
right-click 
(Windows)/ctrl 
+ click (Mac) 
an active Note 

icon to access the context 
menu. Click Delete Note or 
Delete All Notes as 
required:



19

New Guide – precision placement
The requirement to be pixel-perfect is a significant factor in 
web and app design. And another significant factor for web/
app designers (and for any other designer for that matter) is the 
need for speed, as development and turnaround times become 
relentlessly shorter and shorter.

If you are attempting to position a ruler guide manually, at an 
exact pixel location in your image – you’ve moved the mouse 
more than once, and you’re now thinking about zooming in to be 
more accurate – you’ve already wasted time. Use the New Guide 
command instead:

l1 You know exactly where you want to position the ruler 
guide. Choose View > New Guide.

l2 In the New Guide dialog box, select either Vertical or 
Horizontal, then enter the exact pixel measurement in the 
Position entry field.

l3 Press the Return/Enter key to create the 
guide, or click the OK button.

Quicker still! 
The New Guide 
command 
doesn’t have a 
default 

keyboard shortcut. Create 
your own custom shortcut 
and save even more time. 
(See pages 28-30.)
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New Guide Layout – precision grids
Grids have always been important in design and layout for print, 
but there have also been abundant opportunities in print to break 
away from the grid to create interesting visual variation.

On the other hand, from the earliest days, the web has been a 
more constrained, modular, grid-like design environment – initially 
with the popularity of frames, then replaced with table layouts 
and, more recently, “divs”. If anything, unlike print, the grid-like 
structure of web pages has become even more pronounced by the 
requirements of creating mobile-friendly websites and apps.

If you need to create a strong, clearly defined design grid, the New 
Guide Layout command can save you a lot of time and effort.

l1 Chose View > New Guide Layout to show the New 
Guide Layout dialog box.

l2 Use the Preset pop-up to select from the existing presets, 
or to save and load your own column presets.

l3 If you are working in an Artboards document, use the 
Target pop-up to create a guide layout for a specific 
Artboard, or you can apply the same grid to all Artboards.

This document 
is set up as a 
new Artboard 
document, with 
the intention of 

creating a series of 
Artboards based on the 
same layout grid. But, you 
can also use the New Guide 
Layout command in a 
standard Photoshop canvas.
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Creating a custom grid

l1 Click the Columns checkbox, then create settings 
for the number of columns you require and the 
gutter – the space between columns.

l2 Create settings for the number of rows you require 
and the gutter – the space between the rows.

l3 Create settings for margins if required.

...cont’d

Lock/unlock guides

+ + + ;

You don’t have 
to create 
settings for 
every entry 
field. For 

example, you might just 
create settings for margins 
to help define the safe text 
area for a design.
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Artboard documents are a specific type of Photoshop file that 
enable you to create, manage and refine multiple design variations 
on individual Artboards, side-by-side within the same Photoshop 
file. This can be really useful for web and mobile app designers 
creating mock-up designs that need to be optimized for different 
devices and screen sizes. They are equally useful for creating 
multiple versions of a design for an advert or social media post 
that share primary design elements, but need minor design 
variations to be targeted for different social media platforms. In 
essence, each design variation is set up as a separate Artboard in 
the same Photoshop document, meaning that you do not have to 
manage multiple, separate Photoshop files.

l1 To set up a new Artboard document, choose File > New. 
From the document type categories, click either Web 
or Mobile. Notice that for these document types, the 
Artboards checkbox selects by default.

Artboard documents

l2 Click on one of the Blank 
Document Presets to select from 
a preset list of common device 
sizes. Artboard sizes are set in 
pixels. Then, click the Create 

In the New 
Document 
dialog box, for 
Photo, Print, 
Art & 

Illustration, and Film & 
Video document type 
categories, the Artboards 
checkbox is not selected by 
default, but you can switch 
it on if required.

You can convert an existing Photoshop 
document into an Artboard document. 
Select one or more layer groups or 
layers in the document, then right-click 
(Win)/ctrl + click (Mac) the selection. 

Choose Artboard From Layers or Artboard From 
Group.
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button. Alternatively, you can enter your 
own custom settings for Width, Height, 
Orientation, Resolution etc. in the Settings 
area. Click the Create button when you are 
satisfied with your settings.

l3 Notice in the Layers panel, there is a 
single “Artboard 1” entry which contains a 
default layer – “Layer 1”. Also, there is no 
default “Background” layer in an Artboard 
document.

An Artboard document, 
with extensive canvas area 
that can contain multiple 
Artboards of varying sizes.

...cont’d

The Artboard tool
The Artboard tool is grouped with the Move tool. 
Use the Artboard tool to select, move and resize 
Artboards.

If you have the Move tool selected, you can click on 
the edge of an Artboard to select the Artboard tool. 
The Artboard tool also becomes selected if you drag 
one of the corners of the Artboard boundary.

When an Artboard is selected with the Artboard tool, 
Add New Artboard buttons appear along the edges 
of the Artboard.

When you 
create 
additional 
Artboards,  
they do not 

contain a default “Layer 1”.
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Working with more than one Artboard makes it easy to set up 
multiple design variations for a project. You can have multiple 
Artboards of the same dimensions, or you can have mixed sizes, 
making it easy to create mock-ups for mobile and desktop devices 
with different screen sizes. There is a flexible range of techniques 
you can use to create and manage new Artboards.

l1 To create a new Artboard, select the Artboard tool. 
Make sure the Artboard is selected. Click the Add New 
Artboard button (   ) on the side of the active Artboard 
where you want to position the new Artboard. Hold 
down Alt/option, then click the Add New Artboard 
button to duplicate the Artboard and all its content layers.

l2 A new Artboard 
with the same 
dimensions as the 
current Artboard 
appears. A new 
entry for the Artboard appears in the Layers panel.

Create and manage Artboards

l3 You can also create 
a new Artboard by 
choosing Layer > 
New > Artboard. 
Specify Width and 
Height settings in the 
New Artboard dialog box. It’s a good idea to give the new 
Artboard a descriptive name to make it easier to identify.

Think of an 
Artboard as a 
collection of 
layers that form 
a distinct page 

or screen design. Moving 
between Artboards is 
similar to moving from  
page to page in an 
InDesign document. 
Artboards can be of the 
same, or mixed, 
dimensions.

You can also 
select the 
Duplicate 
Artboard 
command from 

the Layers panel menu  
(  ), or the Layer menu, 
to create a duplicate of the 
selected Artboard.
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l4 Alternatively, 
you can create 
a new Artboard 
to the same 
dimensions as the active Artboard by clicking the Add 
New Artboard button in the Options bar. Then, click 
in the canvas area to create the Artboard. You may 
need to reposition the Artboard if you want it to align 
exactly with other Artboards (see the following pages for 
information on using X and Y co-ordinates).

l5 To create a new Artboard manually, select the Artboard 
tool. Position your cursor (   ) on the canvas. Press and 
drag the mouse to define the width and height of the new 
Artboard.

As you drag manually 
to define the size of an 
Artboard, watch for magenta-
colored smart guides that 
help you size and align the 
new Artboard to existing 
Artboards.

Controlling the size of an Artboard
As well as using the measurements readout panel and smart 
guides as you drag to define a new Artboard, you can use a 
combination of controls in the Options bar and the Properties 
panel to specify the exact size and position of Artboards.

...cont’d
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l1 Select an Artboard using the Artboard tool. 
Click the Properties icon in the Panel Dock, 
or choose Window > Properties to show the 
Properties panel if it is not showing.

l2 Enter values in the “W” and “H” fields to specify the 
width and height for the Artboard. Enter values in the 
“X” and “Y” fields to specify the position of the Artboard 
relative to the zero point.

l3 Use the Set Artboard to Preset pop-up in the Properties 
panel to select from a range of standard preset sizes.

0

0

x

y

Common preset screen 
sizes are available in 
the Size pop-up.

l4 You can also use the Size pop-up and/or the Width and 
Height fields in the Options bar.

Renaming Artboards
When working with several Artboards it is a good idea to give 
them distinctive names to make them easy to identify.

l1 To rename an Artboard, double-click on the Artboard 
label in the Layers panel. The existing label highlights. 

...cont’d
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l2 Enter a custom name, then press the Return/Enter key to 
accept it.

Deleting Artboards

l1 To delete an Artboard and all of the content on the 
layers it contains, drag the Artboard onto the Trash at the 
bottom of the Layers panel.

Understanding auto-nesting of Artboard layers
An Artboard acts as a clipping group: if you 
reposition the content of a layer so that it moves 
across the Artboard boundary (in this screenshot 
it’s the radial gradient in the background), the 
content starts to disappear, as the edge of the 
Artboard defines what is visible/invisible.

The content is not lost; it still exists, and 
reappears if you drag it back inside the Artboard 
boundary.

If you drag layer content completely off the Artboard so 
that it sits outside the Artboard boundary, Photoshop 
converts this content to an independent, stand-alone layer 
which appears at the top of the Layers panel.

To move an independent layer back into an 
Artboard, simply drag it onto the Artboard entry 
in the Layers panel, or drag it to a precise location 
in the layer stack of the Artboard as necessary.

To prevent auto-nesting of content into and out of Artboards – 
layers moving out of an Artboard and converting to independent 
layers – you can click the Prevent auto-nesting (  ) button for 
the selected layer or Artboard. A Lock icon appears. Click again 
to release the lock. Note, this does not prevent you from moving 
content outside the Artboard boundary, but it does prevent 
Photoshop from creating an independent layer.

...cont’d
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It goes without saying, to be a fast, efficient, accurate and effective 
user of Photoshop (probably any software), you need to have a 
wide range of keyboard shortcuts dancing off your fingertips.

But, it gets frustrating when you frequently use a command for 
which there is no default shortcut. There are many powerful and 
useful commands introduced in this book that don’t have a default 
shortcut, which is why it is important to be able to set up your 
own custom shortcuts.

This sequence shows you how to set up a keyboard shortcut for 
the Recent Files panel covered earlier in this chapter.

l1 Choose Edit > Keyboard Shortcuts to show the 
Keyboard Shortcuts and Menus dialog box. Make sure 
the Keyboard Shortcuts tab is selected.

l2 To set up your own custom shortcuts you first need to 
create a new keyboard shortcut set. Click the New Set 
button (   ). Use the Save As dialog box to save the new 
keyboard shortcut file. Unless you have a good reason 
for doing otherwise, it’s best to use the same location 

Custom keyboard shortcuts
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that Photoshop automatically opens: [user] \ AppData \ 
Roaming \ Adobe \ Adobe Photoshop CC2017 \ Presets 
\ Keyboard Shortcuts\ (Windows), or [user] \ Library \ 
Application Support \ Adobe \ Adobe Photoshop CC 
2017 \ Presets \ Keyboard Shortcuts (Mac). Enter a 
name. Make sure you retain the .kys file extension and 
that the Save as type pop-up remains set to 
Keyboard Shortcuts (*.KYS). Click Save.

l3 In this example, select Application Menus 
from the Shortcuts For: pop-up menu.

l4 In the Application Menus list box, scroll 
down to Window. Click the Expand 
button (   ). Scroll down to Extensions>, 
then click Recent Files to activate the Shortcut entry box.

l5 Enter the keyboard shortcut you want 
to use for the menu command. 

l6 Click the Accept button if you are going to create more 
custom keyboard shortcuts.

l7 Click the Save All Changes button (   ). Click OK.

...cont’d
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l8 Check 
that the 
command 
now 
displays 
your 
custom keyboard shortcut, and that the shortcut works.

Choosing a custom keyboard shortcut
There are a huge number of keyboard shortcuts already in use by Photoshop and/or the 
operating system. There are two warning messages you might get if you enter a shortcut that 
is already taken.

A red circle warning icon appears if you enter a keyboard shortcut that you cannot use 
because it is already assigned to another command and cannot be changed:

A yellow triangle warning indicates that if you accept the keyboard shortcut for the targeted 
command, it will no longer work for the command to which it is currently assigned:

To save you time, here 
is a range of shortcuts 
that should be available. 
But, treat with caution, 
as even minor upgrades 
to Photoshop sometimes 
introduce unexpected and 
undocumented changes. 
(Other combinations are 
available that are not listed.)

Alt + Shift combinations 
(Win):

Alt + Shift + F1

Alt + Shift + F2

Alt + Shift + F3

Alt + Shift + F5, F6, F7, F8, 
F9, F10, F11, F12

Alt/opt + ctrl/com 
combinations:

Win

Alt + ctrl + F9

Alt + ctrl + F10

Alt + ctrl + F11

Alt + ctrl  + F12

Mac

alt/option + cmd + .

alt/option + cmd + ‘

alt/option + cmd + F

alt/option + cmd + Q

alt/option + cmd + P

Alt/opt + Shift + cmd 
combinations:

Mac

alt/option + Shift + cmd + Z

alt/option + Shift + cmd + .

alt/option + Shift + cmd + ;

alt/option + Shift + cmd + H

alt/option + Shift + cmd + G

alt/option + Shift + cmd + D

...cont’d



31

Auto-Select
Auto-Select is now on by default: when you have the Move tool 
selected and you click on an object in a Photoshop file with layers, 
you automatically select its layer in the Layers panel. This is often 
convenient and useful – saving you from having to go to the 
Layers panel, find the layer you want to target, click on it to select 
it and then bring your cursor back into the artwork to work on 
the object/layer.

However, there are times in complex layered files that Auto-Select 
can be less convenient and not what you want to happen all the 
time – especially as your compositions become more and more 
complex with masks, varied layer opacity, feathering, and the like.

Use the following techniques to give yourself flexibility, control 
and precision as you work with layers.

l1 Turn off the Auto-Select checkbox in the Options bar.

l2 With the Move tool selected, hold down ctrl/cmd. As you 
move your cursor over the various elements on different, 
overlapping layers, a magenta bounding box appears 
around the contents of the layer and “smart” measurement 
guides appear, depending on where you position your 

With the Move tool selected, 
hold ctrl/cmd and position 
your cursor just on the edge 
of the magenta bounding box 
to display distances to the 
edge of the canvas. 

With the Move tool selected, hold 
ctrl/cmd and position your cursor 
over an object on a different layer 
to see measurements relating to 
the active layer and the layers your 
cursor is over.
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cursor. For example, indicating the distances from the 
edges of the layer content to the edges of the canvas, or 
from the contents of the active layer to the contents of 
the layer you move your cursor over.

l3 Still with the ctrl/cmd key held down, click inside a 
magenta bounding box to select that layer.

l4 Another very flexible way to select a specific layer in 
complex artwork is to position your Move tool cursor over 
some of the content on the layer you want to select, then 
right-click (Win)/ctrl + click (Mac) to access a context 
menu of 
layers under 
the cursor. 
Click on the 
layer name 
you want to 
work with.

l5 The Group/Layer pop-up menu in the 
Options bar controls whether you select 
only the specific layer on which you click, 
or the layer group – if the layer is within a layer group.

When selecting 
layers using the 
context menu, 
you can hold 
down Shift and 

click on additional layers to 
select multiple layers.

Show Transform 
Controls

Working with the Move 
tool, if you switch on Show 
Transform Controls in the 
Options bar, when you select 
a layer in the Layers panel 
the transformation bounding 
box for the layer contents 
appears automatically. This 
can sometimes be very useful, and very 
annoying on other occasions. Consider 
switching the option off and using the 
keyboard shortcut for Free Transform as 
and when you need it: +

T

...cont’d
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