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1Entering data with Auto Fill

If you’re typing in data that has a pattern to it, Excel can 
complete the pattern for you. You can use this for number 
sequences, times, and dates.

l1 Enter the start of the sequence into two cells. If it’s 
a number sequence, you’ll need to enter at least 
two numbers. For times and dates, Excel can use 
just one. For alternate months (January, March, 
etc.), you’d enter the first two to show the pattern.

l2 Highlight the cells containing your data.

l3 Click the Fill handle. It’s a tiny 
dot in the bottom right of 
the selected area. Your cursor 
becomes a small black cross 
when you hover over it.

l4 Drag the mouse to cover 
the area you want to fill. In 
the example shown here, you’d drag down. As 
you drag, you’ll see the value that’s being added 
shown next to your cursor.

l5 Click the Auto Fill Options menu that appears 
beside your cursor to find options for the fill, 
including Copy, which fills each cell with the data 
you’ve selected. You can also fill weekdays, days, 
months, or years from dates. Try putting 31-Jan 
in the first box, then autofilling months to get the 
last day of each month.

l6 Even quicker: If you just want a sequence of 
numbers going up by 1, enter the first number, 
select the cell and hold down Ctrl while you drag 
the Fill handle.
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2 Filling to match 
the neighboring column

There’s an even quicker way to autofill a range so it matches 
the size of the neighboring columns.

l1 Enter the first two data items in the sequence you 
want to use. For example, if you want to add years 
starting at 2025 and want to increase by 1 each 
time, enter 2025 and 2026 into two cells.

l2 Highlight both cells containing the data items you 
just entered.

l3 Double-click the Fill handle in the bottom right of 
the selected area.

l4 Your data column is 
automatically filled 
to match the size 
of the neighboring 
columns. In my 
example, the 
autofill extends to 
where the data 
ends in the third 
column, even 
though the nearest 
column is shorter.
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3Using Flash Fill 

Introduced in Excel 2013, Flash Fill recognizes patterns 
in data based on neighboring cells. It’s much more 
sophisticated than Auto Fill. You can use it, for example, to 
reformat text and split or combine data. Here’s an example.

l1 You might have a list of names, with the first name 
and last name combined. For the first row, type the 
first and second names into the next cells. This is 
how you teach Excel the pattern to copy.

l2 Position your cursor in the empty first name cell for 
the second name. 

l3 Press Ctrl + E or click the Flash Fill button on 
the ribbon. Find it by clicking the Data tab, then 
looking in the Data Tools.

l4 The first name column is then automatically filled 
out for you. Check the results look okay, and then 
do the same for the last name column.
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4 Adjusting column 
widths and row heights

Here are some tips for adjusting the width of columns. 
Similar ideas apply to rows.

l1 To adjust the width of a column, click and drag 
the line to the right of its letter above the column. 
Here, I’m adjusting the width of column C.

l2 To make the column width snap to the width of 
the content in the column, double-click this same 
dividing line above the column, on its right.

l3 You can select several columns and adjust them 
at the same time, making them equal width, or 
making them all snap to their content width. To 
select a column, click its letter. Click and drag on 
the letters to select multiple columns, or use Ctrl + 
click to select columns that aren’t adjacent.

l4 You might want to set the column width to a 
particular cell in the column, rather than the widest 
cell. Perhaps one cell contains a title that you’re 
happy to run into other cells. Select the cell you 
want to adjust the width to, go to Format in the 
Cells group of the Home tab, and select AutoFit 
Column Width.
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5Inserting 
multiple rows or columns

I’ll show you how to quickly insert multiple rows. You can 
use a similar technique to insert columns.

l1 Click the number of the row where you want to 
insert above, and drag down for as many rows as 
you want to insert. For the example here, I want to 
insert three rows above row 4.

l2 Click Insert in the Cells group of the Home tab. You 
could alternatively use Ctrl with the plus symbol 
(+). You can use the + key on your number 
keypad or add Shift to the key combination to use 
the key on the main keyboard.

l3 If you’re inserting a row to copy another row into 
it, you can save time by copying the row first. 
When you insert, your copied row will be pasted 
into the new row(s).



10

6 Managing  
large spreadsheets

There are several techniques that can help you to manage 
large spreadsheets.

l1 On the View tab, click New Window to see 
your worksheet in another window at the same 
time. You can scroll around in the windows 
independently, but it’s just two views of the same 
document. Any changes you make will be visible in 
both windows. Use Arrange All on the View tab to 
organize your windows side by side.

l2 Keep column and/
or row headings 
in view when 
you scroll. Also 
on the View tab, 
Freeze Panes can 
keep the top row 
or first column 
in view. You can 
freeze both by selecting the cell that is underneath 
the column heading and to the right of the row 
heading that you want to keep, and then choosing 
Freeze Panes. Using this approach, you can freeze 
several rows or columns.

l3 Focus on what’s 
important by 
hiding rows and 
columns you don’t 
need right now. 
Select the rows or 
columns (click and 
drag on their letters or numbers in the margin), 
and choose Hide Rows or Hide Columns. These 
options are on the Home tab, in the Editing group, 
under the Format menu.
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7Forcing valid data entry

To improve data quality, you can validate data as it is 
entered into the spreadsheet.

l1 Select the cells you want to apply validation to.

l2 Click Data Validation on the Data tab of the 
ribbon. The Data Validation options open.

l3 In the Allow menu, you can choose to allow any 
value (the default), whole numbers, decimals, 
dates, times, or text of a certain length. You can 
also define custom validation (see Tip 9) or use a 
list of valid data items (see Tip 8). 

l4 In the Data menu, you can choose a sequence 
of valid values (between), minimum and/or 
maximum values, or a sequence of invalid values 
(not between). Use the boxes below to enter the 
start and end dates, or minimum and maximum 
numbers. Use the Input Message tab to give users 
instructions on entering valid data. Instructions are 
shown when users select the cell.
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8 Adding a drop-down menu

You can ensure data is valid and speed up its entry by 
putting a drop-down menu in a cell. This is one of the data 
validation options.

l1 Select the cell(s) where you want to use the menu. 

l2 Click Data Validation on the Data tab of the ribbon 
to open the Data Validation options. There’s a 
shortcut: press ALT, D, and L one at a time.

l3 In the Allow 
drop-down 
menu, 
choose List.

l4 In the 
Source box, 
type the 
menu items, 
separated by 
a comma. 
Click OK.

l5 If you prefer, you can use data that’s in a 
spreadsheet row, column, or named range (see 
p.41). In that case, enter an = sign followed by 
the name in the Source box, or enter = there and 
then select the menu items on the spreadsheet 
using the mouse. It’s easy to edit your menu later 
by simply editing those cells.

l6 When you select one of 
the cells, a menu will 
appear so you can select 
the data you’d like to 
enter in that cell.
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9Creating custom validation

You can write your own validation rules. Select the cell(s) 
you want to validate and go to the Data Validation options 
(see Tip 7). Select Custom in the Allow menu. In the Formula 
box, enter a formula that gives a result of TRUE or FALSE. 
Here are some examples to validate cell J8:

• Must start with text “CPC”. =COUNTIF(J8, “CPC*”)=1

• Length must be 3. =LEN(J8)=3

• Must be a number. =ISNUMBER(J8)

• First character must be a number. The LEFT function 
is used to extract the character, and ISNUMBER is 
used to test whether it is a number. The VALUE 
function is required because in a data item like 
“UK-52”, the 52 would otherwise be treated as text. 
=ISNUMBER(VALUE(LEFT(J8,1)))

• Last character must not be a number. To see whether 
a character is not a number, we can check whether it 
is a number, and then wrap it in the NOT function to 
reverse the result.  
=NOT(ISNUMBER(VALUE(RIGHT(J8,1))))

• Must be unique in column J. This shows an error if 
the same data has already been entered in the same 
column. =COUNTIF(J:J, J8)<=1

• Must be odd. =ISODD(J8). ISEVEN can be used, too.

To allow multiple options, join them with OR, like this 
example, which allows data of 3 or 5 characters to be valid:

=OR(LEN(J8)=3, LEN(J8)=5)

To enforce multiple validation rules, use AND, like this 
example, which requires a 3-character code starting with A:

=AND(LEN(J8)=3, COUNTIF(J8, ”A*”)=1)
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10 Removing duplicates

You can remove duplicated data in a spreadsheet, which 
can easily happen if data such as mailing list information is 
combined from multiple sources.

l1 Click in your data so Excel can find it.

l2 Click Remove Duplicates on the Data tab of the 
ribbon. You’ll find it in the Data Tools group.

l3 Select the columns that you want to check for 
duplicate entries. It’s safest to keep them all 
selected. If you just selected the First Name and 
Last Name (for example), two different people who 
share a name would be identified as duplicates, 
even though they have different addresses. One of 
them would be automatically deleted. This doesn’t 
happen if you select the address fields as well.

l4 Click OK. Beware, though, as that might 
delete rows from your spreadsheet. Use Undo 
immediately to bring them back if you made a 
mistake.
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11Highlighting duplicates

You might be storing the same person twice, at their new 
and their old address. You can highlight duplicated data so 
you can fix it manually.

l1 Select the cells you want to check for duplicates. 
In a mailing list spreadsheet, this might be the First 
Name and Last Name columns.

l2 On the Home tab, click Conditional Formatting. 
Select Highlight Cells Rules and choose Duplicate 
Values.

l3 You can choose to 
highlight duplicate 
or unique values, 
and can pick your 
preferred color and 
formatting option.

l4 This isn’t smart enough to recognize first and 
second name combinations, so all the occurrences 
of Ben would be highlighted, even if they have 
different surnames. Even if the first name and 
surname are both highlighted, it might not be 
a repeated person, because the names might be 
shared with different people. It’s a good first pass 
for a manual review, though.
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12 Using 
 advanced paste options

There are lots of advanced paste 
options. Cells can contain formulas, 
values (which are formula results, or 
numbers or text entered directly) and 
formatting. You can paste each of these 
independently.

Click the arrow on the Paste button on 
the Home tab to find advanced paste 
options. For example, you can paste:

• Formulas and number formatting 
(such as currencies) without 
overwriting other formatting.

• Values only. This is useful if you 
want to copy the result of a 
formula, but not the formula itself.

• Formatting only (see also Tip 67 – the Format Painter). 

• Everything except borders.

• Everything, keeping the original column widths.

• Everything, but transposing (or swapping over) the 
rows and columns. Here’s an example: Compare the 
left table with the right one.

Paste Special includes the option to skip blanks or to carry 
out a mathematical operation. For example, copy 2 and 
paste with Divide to halve the numbers you paste over. To 
make negative numbers positive, copy -1 and paste it on top 
of the negative numbers with the Multiply option. 
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13Expanding the clipboard

If you’re moving lots of information 
around, you can use the clipboard to 
store multiple items you’ve copied.

l1 Click the tiny arrow to the right 
of the Clipboard label on the 
Home tab.

l2 The clipboard expands into a column on the left. 
You can click any of the items in the clipboard to 
paste them at your cursor’s current position.

l3 Click the menu 
button that appears 
when you hover 
over an item in 
the clipboard, and 
you can choose to 
delete that item. 
This is useful if the 
clipboard contains 
data you no longer 
need and it’s getting 
in the way.

l4 You can empty the 
whole clipboard by 
clicking Clear All at 
the top.

l5 You can use Paste All at the top of the clipboard 
to paste all the data in one go. You might get 
unexpected results if the data is not similar in 
its structure, because you’ve been copying from 
different parts of the spreadsheet.
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14 Moving data

There is an easier way to move data around your 
spreadsheet than copying and pasting it.

l1 Select the data you want to move by clicking the 
start cell and dragging with the mouse.

l2 Move your mouse cursor over 
one of the edges of the selected 
area. The cursor becomes a 
four-headed arrow.

l3 Click and drag with your 
mouse. An outline will follow 
your mouse cursor showing 
how much space the selected 
area will occupy.

l4 Release the mouse button to drop the data in its 
new position on the spreadsheet.

You can use that technique to move an entire row or 
column after selecting it, but it will overwrite what’s already 
in the cells you move to. Alternatively, you can cut a column 
and then insert a new column and paste your data into it at 
the same time. This also works for rows.

l1 Select the column you want to move. You can 
select several consecutive columns to move using 
Shift + click to select the first and last one. 

l2 Use Ctrl + X to cut the data.

l3 Select the column to the right of where you want 
to insert a new column. Click Insert on the Home 
tab of the ribbon to move the columns you cut.
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15Entering formulas

Here are some tips for entering formulas in cells.

l1 If you don’t know the name of the function 
you need, you can click the fx button beside the 
formula bar to search for it by description.

l2 When you’re entering a function name, Excel 
can help you complete it. A menu opens with 
function names that match what you’ve typed 
so far. You see a description of the function 
too. Use the Up and Down arrows to choose an 
option. Use Tab to select the option. You can 
then use Shift + Ctrl + A to have placeholder 
values inserted in your formula. For example: 
=MAX(number1,number2,...)

l3 If you’ve named cells or ranges (see Tip 37), tap F3 
to paste a name from a menu into your formula.
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16 Understanding 
formula symbols

Here’s a handy reference to the symbols used in formulas:

• All formulas start with =

• Use $ to fix cell 
references. When I 
copied the formula 
from cell C2 into C3 
and C4, it updated the 
row references in the 
formula. As a result, cell C4 adds up the cows (A4) and 
sheep (B4) in that row, which is the expected result. If you 
don’t want the row to change when you paste a formula, 
put a $ in front of it (for example, A$2). If you don’t 
want the column to change, put a $ in front of that 
(for example, $A2). You can fix both too (for example, 
$A$2). You do this in your formula before you copy it.

• You can cycle through the options for fixing rows, 
columns, and both in a cell reference by tapping F4.

• Use a colon between cells to make a range. A2:A4 is 
the range of cells containing all the cows. A:A means 
all of column A, and 2:2 would be all of row 2.

• Put ! at the end of a sheet name. For example, to use 
cell C3 in Sheet6 from a different worksheet, your cell 
reference would be Sheet6!C3.

• Put parentheses () around the data used by functions. 
Each opening parenthesis needs a closing one.

• Use + for addition.

• Use - for subtraction.

• Use * for multiplication.

• Use / for division.
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17Finding the highest/ 
lowest value in a range

You can use the MAX function to find the highest value 
(or latest date) in a range or set of numbers. There is an 
equivalent function called MIN that you can use to find the 
lowest number (or the earliest date) from a range.

l1 Click on the cell where you want the result to be.

l2 Type in =MAX(

l3 Select the cells with the mouse, or type in the 
range coordinates.

l4 If you want to add another range, type a comma 
and then select the new range.

l5 Press Enter to add the closing parenthesis ) and see 
the result in the spreadsheet.

You can access both MIN and MAX using the Autosum 
button on the Home tab:

l1 Select the range you want to analyze, typically a 
column or row of numbers.

l2 Click the small 
arrow beside the 
Autosum button on 
the Home tab.

l3 When the menu opens,  
click Min or Max. The 
result is added at the 
end of your range.
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18 Ranking data items

You can use the RANK function to show you how a data 
item ranks compared to others. For example, you can use it 
to quickly spot the biggest sale, without sorting the data.

The RANK function works like this:

=RANK(cell you want to rank, cell range you want to 

compare it against, ranking order)

The ranking order parameter at the end is optional. The 
default value of 0 is the order we usually use for bestselling 
book and music charts, where 1 represents the biggest seller, 
and the rank numbers increase for lower sales volumes. 

Add a ranking order of 1 to reverse the order, so the lowest 
value is ranked 1. For example, you might use this when 
comparing speed, based on the time taken (the fastest car 
took the least time).

If you want to copy your RANK function down your column, 
remember to add a $ before the row numbers for the 
comparison range so they aren’t changed as the function 
is copied. For example, looking at the worksheet below, my 
function to rank the first sales figure in column B is:

=RANK(B2,B$2:B$7)

I’ve copied this formula down column D.
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19Finding an item by 
its ranking using LARGE

The MAX and MIN functions give you the highest and 
lowest numbers in a range. To find an item at other 
positions in the ranking, use the LARGE function.

l1 Click on the cell where you want the result to be.

l2 Type in =LARGE(

l3 Select the cells with the mouse, or type in the 
range coordinates. In my screenshot, the range 
is sorted so you can easily check the data. This 
function is probably most helpful when the data 
isn’t already sorted.

l4 Type a comma, followed by the position number of 
the item you want to find. For example, to find the 
second biggest number in the range, use 2.

l5 When you’ve finished, press Enter to complete the 
formula and see the result in the spreadsheet.
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20 Finding averages

Excel provides three functions to find the average value from 
a range of cells.

If you wanted to find the average of the values in the cells 
A1 to A10, you could use:

• =AVERAGE(A1:A10). This is the average most people 
think of first: it’s calculated by adding up all the values 
and then dividing by the number of data items. It’s the 
arithmetic mean. 

• =MEDIAN(A1:A10). This is the value in the middle of 
the range when it is sorted in number order. That’s 
how it works if your list has an odd number of items. If 
your list has an even number of items, there is no item 
in the middle, so this gives the mid-point between the 
two middle items. In that case, it returns a number that 
is not in your range.

• =MODE(A1:A10). This returns the most frequently 
occurring value, irrespective of whether it is high or 
low, or somewhere in between.

You can use the Autosum 
menu on the Home tab of 
the ribbon to calculate the 
average (arithmetic mean).

If you just want to do a 
quick check of the average, 
highlight the cells and look 
at the status bar in the 
bottom right. If your monitor 
is wide enough, it shows the 
average, count, and sum for 
the selected range.
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21Sorting data

You might find data is not in the right order. Let’s sort it!

l1 Click a cell in the column you wish to sort if you’re 
sorting all your data, or select the data to sort.

l2 On the Home tab, in the Editing group, click Sort 
& Filter. If available, select the option you require, 
such as sort Oldest to Newest, Newest to Oldest, 
Smallest to Largest, or Largest to Smallest.

l3 It is possible to sort by multiple criteria – for 
example, sort first by date and then sort by the size 
of the sales within each month. If you need to sort 
by two or more criteria, click Custom Sort in the 
Sort & Filter menu.

l4 Use the Add Level, Delete Level and Copy Level 
buttons to add or remove sorting criteria.

l5 In the Sort On menu, you can sort by cell color, 
font color, and conditional formatting icon, as well 
as the cell value.

l6 If you need to sort left to right instead of top to 
bottom, click Options and change the orientation.
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22 Using filters

Filters show you only the rows that contain certain values. 

l1 Click in the data where you want to add a filter.

l2 On the Home ribbon, in the Editing group, open 
the Sort & Filter menu. Click Filter.

l3 Filter buttons are added 
to your column headers. 
Click one to open the 
options. Select which 
values from that column 
you want view.

l4 Click OK, and you see 
only the rows that 
contain your chosen 
values. Where a filter is 
active, there is an icon 
in the Filter button at 
the top of the column. The row numbers may 
also tell us that some rows are not shown. In my 
example below, I’ve filtered the product category 
to show only “Gardens” sales. You can filter several 
columns at the same time, so I could use the filter 
in the Customer column to see sales of Garden 
equipment to ABC, for example. Use Clear Filter in 
the Filter options (shown in the picture above) to 
turn off the filter.
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23Using IF for cell contents

Excel can decide what should be in a cell using the IF 
function. It uses this format:

=IF(decision criterion, cell value if true, cell value if false)

For example, here’s a spreadsheet showing monthly sales 
and sales targets.

I used this formula in cell D2 then copied it down column D:

=IF(B2 >= C2, “”, “Missed target”)

The ““ is an empty value, so column D is empty when the 
target has been achieved, and the warnings stand out. 

You can use all the operators for your comparison: 

• = to test whether two values are the same.

• <> to test whether two values are not the same.

• > to check if the first value is more than the second.

• < to check if the first value is less than the second.

• >= to ask whether the first value is more than or 
equal to the second.

• <= to ask whether the first value is less than or equal 
to the second.
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You can combine IF functions together, by putting one inside 
another. This is called nesting them. For example, let’s say 
you wanted to label a number as high, medium, or low, 
depending on its value. A value of 100 or lower is low, 101 
to 200 is medium, and over 200 is high.

You can check whether a value in cell F4 is low, like this:

=IF(F4 <= 100, “low”, “not low”)

You can check whether a value is high, like this:

=IF(F4 > 200, “high”, “not high”)

We want to combine these functions, so that Excel works 
through this thought process:

• Is the number less than or equal to 100? If so, it’s low.

• If it isn’t a low number, let’s see whether the number is 
higher than 200. If so, it’s a high number.

• If it’s not a high number, and we know it’s not a low 
number, then it must be medium.

Instead of just displaying “not low” when the value isn’t 
low, we can go straight into another IF function that checks 
whether it’s high. This is what it looks like, all together:

=IF(F4 <= 100, “low”, IF(F4 > 200, “high”, “medium”))

Excel 2016 introduced the IFS function, which is easier to 
use. You give it a list of decision criteria and the cell value if 
true. To create a default value for when none of the criteria 
is true, provide a final decision criterion of TRUE with a 
default value. Here’s our high/medium/low cell labeler again:

=IFS(F4 <= 100, “low”, F4 > 200, “high”,  
TRUE, “medium”)

Combining IF functions



29

25Totaling up values with SUM

To create a total, you can use the SUM function. You provide 
it with a range of cells you want to sum. Here’s an example 
spreadsheet showing money received.

• To create the total in cell B12, you can enter 
=SUM(B2:B11) into cell B12. You can type in the cell 
range, or you can select the range using the mouse 
after you type the opening parenthesis in the formula.

• You can also use the Autosum button on the Home 
tab of the ribbon. Put your cursor in cell B12 then click 
the Autosum button. It will enter the SUM formula and 
automatically select the range.

• Even quicker: use the keyboard shortcut. Click on cell 
B12 and then press Alt + = to enter the SUM formula 
and automatically select the range.

• You can also use this shortcut and the Autosum button 
to total cells to the left in the current row.
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26 Choosing values 
to sum with SUMIF

Sometimes, you might want to total up some of your data 
but not all of it. For example, you might want to get the 
sales receipts from June 2022 only. 

You can use the SUMIF function to do this. The format is:

=SUMIF(range to compare, value to compare that range 

against, data range to add up)

Here’s a breakdown of those three parts to the formula:

• The cells you want to compare against. 

• The value you want to compare them to – for example, 
“Jun-22”. The value you want to compare will usually 
be in quotation marks – for example, “Jun-22” for a 
date, “>21” for values of more than 21, or “blue” 
to match that word. You can match the contents of 
another cell by using its cell reference, but shouldn’t 
use quotation marks with it (for example, D2). You 
don’t need quotation marks around a number, either.

• The cells you want to total. 

To add up all the sales in June 2022 in rows 2 to 10 of the 
spreadsheet shown below you would enter this into a cell: 
=SUMIF(C2:C10, “Jun-22”, B2:B10)

Beware: If the range you’re adding up is smaller than the 
range you’re comparing in any direction, the range you’re 
adding may be extended, leading to unexpected results.
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Sometimes, you might want to select data for totaling 
using more than one criterion. For example, using our sales 
spreadsheet again (see Tip 26), you might want to total the 
sales receipts in June 2022 for cutlery. That involves checking 
the values of two different cells (category and date), before 
totaling up the number in a third cell (sale value). 

To do that, you use the SUMIFS function. 

The catch is that the data to sum and the criteria are 
entered in a different order when you use SUMIFS, 
compared to SUMIF. You enter data in this order:

• The data you want to total.

• The first range of cells you want to evaluate.

• The value you want to compare them to.

• The second range of cells you want to evaluate.

• The value you want to compare them to.

The format is:

=SUMIFS(data to add up, range to compare, value to 

compare that range against, second range to compare, 

value to compare that range against)

You can use more criteria if you wish: you don’t have to 
stop at two.

To add up the cutlery sales from June 2022 in our example 
spreadsheet (see Tip 26), we’d use:

=SUMIFS(B2:B10, C2:C10, “Jun-22”, A0:A10, “Cutlery”)

The size and shape of the ranges you are adding up and the 
ranges containing your criteria must be the same.

Using several 
sum criteria with SUMIFS
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28 Using cumulative sums

A cumulative sum is the “total so far”. For example, if you’re 
working on a calendar year, March’s total would include the 
data for March, February, and January, to show the sales in 
the year up to that point. Cumulative sums can be useful for 
benchmarking performance against previous years.

There isn’t a built-in function to calculate cumulative sums, 
but you can use the SUM function to do this. The solution is 
to fix the starting cell for the range you want to sum, but to 
leave the end cell as a relative reference. 

Here’s a worked example:

l1 We want to calculate the cumulative total of the 
sales that are shown in column B. In cell C2, enter 
=SUM(B$2:B2). (The start and end of the range 
are the same here, because there’s only one month 
to total.)

l2 Copy the formula down the column.

l3 As the formula is copied, the end of the range 
will be updated. For example, in June, the formula 
becomes =SUM(B$2:B7). Fixing the first cell 
reference in the formula means it always starts 
totaling with January’s sales figures.

l4 You can ignore the warnings that adjacent cells are 
not included in the formula.
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29Using SUMPRODUCT

Working out a grand total sometimes involves multiplying 
different values together. For example, your spreadsheet 
might show the price and quantity sold for each item. 

You could calculate the sales value for each item by 
multiplying the quantity sold by the price, and then adding 
all these values up. But the SUMPRODUCT function does this 
in a single step for you.

The function works like this:

=SUMPRODUCT(first range, second range)

It is possible to add additional ranges to multiply together. 
You could, for example, add a third column with the 
percentage margin for each item to work out the profit on 
the goods sold.

Here’s a worked example.

l1 Put the unit price in column B.

l2 Put the quantity sold in column C.

l3 The grand total will be the sum of the unit price 
multiplied by the quantity for each row. To work 
this out, use =SUMPRODUCT(B2:B4, C2:C4)
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30 Counting cells

There are four functions you can use to count cells. Let’s 
imagine you want to count the cells in the range C1:C10. 
You could put one of these functions into another cell to see 
the result of the count. See the example below, where each 
function is used to count the column of data above:

• =COUNT(C1:C10). This counts the number of cells 
containing numbers and dates, in the range given in 
parentheses. This can be useful if you don’t want to 
count cells containing text, such as headings.

• =COUNTA(C1:C10). This counts text, as well as 
numbers and dates. It gives you a total for the non-
blank cells in your range.

• =COUNTBLANK(C1:C10). This counts how many empty 
cells there are in the given range. You can use this to 
identify where your data might be incomplete.

• =COUNTIF(C1:C10, “>25”). The COUNTIF function 
enables you to count the number of cells that meet 
certain criteria. It’s similar to SUMIF (see Tip 26). Inside 
the parentheses, you put the range first and then the 
criteria to match.
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31Using more count criteria

You can count cells that meet several criteria using the 
COUNTIFS function. It takes this form:

=COUNTIFS(range to compare, value to compare against, 

second range to compare, second value to compare 

against...)

In the spreadsheet below, we want to count the number of 
orders delivered to London worth more than $400.

l1 Click on the cell where you want the result to be.

l2 Enter =COUNTIFS(

l3 Click at the top of column K to select the column.

l4 Type a comma, and then “London”.

l5 Type a comma, and then select column N.

l6 Type a comma, and then “>400”. Press Enter.

l7 Your final formula looks like this: =COUNTIFS(K:K, 
“London”, N:N, “>400”)
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32 Using wildcards

You can use wildcards to do an inexact match with a 
piece of text. A wildcard is a character that stands in for 
one or more other characters. Wildcards can be used with 
COUNTIF/COUNTIFS and SUMIF/SUMIFS as well as some 
other functions, but cannot be used with IF. 

There are three wildcards:

• ? (question mark). Stands in for any single character. 
For example, “a?e” would match both “ape” and “ace” 
but not “apple”.

• * (asterisk). Matches any number of characters. For 
example, “cut*” would match both “cutlery” and 
“cutlass”.

• ~ (tilde). Is used before a * or ? if you actually want to 
look for one in the text.

Here are some examples, based on counting the cells in the 
range A1 to A10:

• =COUNTIF(A1:A10, ”<>??-????”). Checks for cells 
that do not contain data in the form of two characters, 
a dash, and then four characters. Checks like this can 
be used for validating order numbers and similar codes. 
Note that blank cells are counted in this case, so don’t 
set the range as the whole column.

• =COUNTIF(A1:A10, ”BB*”). Counts orders beginning 
with the letters BB.

• =COUNTIF(A1:A10, ”*~?”). Counts cells that end with 
a question mark. The * stands in for any number of 
characters at the start of the text. The tilde is required 
so Excel knows you want to match a question mark, 
not use it as a wildcard.
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33Grouping data

To make it easier to understand your spreadsheet, you can 
group rows or columns. You can easily hide and show 
groups using buttons in the margin.

l1 If your data includes summary rows (see 
screenshot), Excel can automatically create groups. 
Click in your data. In the Outline group of the Data 
tab, open the Group menu and select Auto Outline.

l2 Alternatively, select the rows or columns you 
want to combine into a group. They must be 
consecutive: you can’t have an unselected row or 
column in the middle.

l3 In the Outline group of the Data tab, click Group. 
This combines your selected data into a group.

l4 Use the + and - signs in the left and top margins 
to show and hide your groups.

l5 You can create a group inside another group.

l6 To clear a group, select the rows/columns in the 
group and then click Ungroup. You can remove 
all groups using the Clear Outline option under 
Ungroup. It doesn’t delete any data.
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34 Calculating subtotals

Excel’s subtotal feature does the work of the SUM function, 
combined with automatic grouping.

l1 Sort your data so it’s organized how you want to 
subtotal it. For example, if you want to subtotal 
your expenses monthly, sort your data by month.

l2 Click in your data.

l3 On the Data tab of the ribbon, in the Outline 
group, click Subtotal.

l4 In the first menu option, tell Excel how you want 
to group your data. For example, you might want 
to generate a subtotal for each month change.

l5 Choose the function you want to use. Typically, 
this will be Sum. But you can also count items, 
calculate an average, and show the maximum or 
minimum values, among other things.

l6 Select which columns you want to be subtotaled 
and click OK.
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35Using subtotals

This is how you can use automatically generated subtotals.

l1 Click the minus sign beside a subtotal to close the 
group, leaving only the subtotal visible.

l2 Click the 1 button above the left margin to see the 
grand total of all the subtotaled items.

l3 Click the 2 button above the left margin to see the 
subtotals. You can expand any of them by clicking 
the plus button beside it.

l4 Click the 3 button above the left margin to see all 
your data again.

l5 To remove your subtotal, click Subtotal on the 
ribbon. It’s in the Outline group of the Data tab. In 
the options that appear, click Remove All.
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36 Copying visible data only

When you copy data, any cells that are hidden will be 
copied with it. For example, any groups you’ve closed or 
rows you’ve hidden will be copied.

l1 Select the data you want to copy, which may 
include hidden groups.

l2 On the Home tab, in the 
Editing group, open the 
Find & Select menu. Click 
Go To Special... (see image 
on the right). The shortcut 
is Ctrl + G.

l3 In the Go To Special menu, 
shown below, select 
“Visible cells only”.

l4 Click OK.

l5 Now you can copy and paste in the usual way, 
using Ctrl + C to copy, and Ctrl + V to paste.
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37Naming ranges

You can simplify your formulas by naming ranges. For 
example, if you name a range “sales”, you could use the 
formulas =SUM(sales) or =AVERAGE(sales). Names cannot 
include spaces, but you can use an underscore character.

l1 Select the range you want to name.

l2 The Name box is beside 
the formula bar. It usually 
contains the selected cell 
reference, or the size of the 
selected range while you are 
selecting it. Type in the name 
you want to use and press 
the Enter key.

l3 Alternatively, you 
can click Define 
Name on the 
Formulas tab of 
the ribbon. Here, 
you can add a 
comment, and 
change the scope 
if you want the 
name to only apply to this worksheet and not the 
whole workbook. You can edit the range the name 
refers to in the “Refers to” box.

l4 You can also put a number or a formula in the 
“Refers to” box. For example, you could define a 
name as =20% for discount calculations. If you 
change this value later, formulas based on the 
name recalculate. You could give a name to a 
formula =SUM(C:C) to avoid re-entering it each 
time you want to use the sales total.
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38 Using the Name Manager

You can see the name of a range in the Name box if you 
select the whole range. The most useful way to see and 
manage your named ranges and values, though, is to use 
the Name Manager.

l1 On the Formulas tab of the ribbon, click Name 
Manager to open it.

l2 Click a name to see the range, constant number, 
or formula it refers to at the bottom of the Name 
Manager pane.

l3 Double-click a name or select it and click Edit if 
you want to change what it refers to. You can’t 
change a name’s scope once it’s been defined.

l4 Select a name and click Delete to delete it.

l5 Use the filter in the top right to show names with 
errors. Excel will adjust the named range if you add 
or remove data within the range, but if you delete 
all of the data in the named range, it causes an 
error. Any cells using the name will show #REF. 
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39Using VLOOKUP

You can use the VLOOKUP function to find a value in a set of 
data, and use it in a formula. The function works by searching 
a column for your data. (If you haven’t used VLOOKUP before, 
try Index-Match instead – see Tips 41 & 42).

VLOOKUP works like this:

=VLOOKUP(data to match, range to find it in, column 
number in that range where your desired data is, type of 

match)

It’s easiest to understand with a worked example.

In this spreadsheet, let’s say we want to look up the 
quantity of crisps sold. (We’ll use the text “Crisps” but you 
could use a cell reference to search for a cell’s contents 
instead.) The data is in the range A1:C7. The word we’re 
looking for must always be in the first column of the range, 
and we call that column number 1. The quantity sold is in 
column 3, then. There are two types of match you can use. 
For an exact match, use FALSE.

This is what the final formula would look like:

=VLOOKUP(“Crisps”, A1:C7, 3, FALSE)

The other match type is an inexact match (chosen using 
TRUE), where the function returns the nearest value lower 
than the chosen value. You might want to use this when 
you’re looking up numbers instead of text.
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40 Using HLOOKUP

The HLOOKUP function is similar to VLOOKUP (see Tip 39). You 
use it to find a value in a set of data, but you search across 
a row to find the data. If this is the first time you’ve come 
across HLOOKUP, try Index-Match instead (see Tips 41 & 42).

HLOOKUP works like this:

=HLOOKUP(data to match, range to find it in, row 
number in that range where your desired data is, type of 

match)

In the spreadsheet shown here, let’s say we want to be able 
to look up the June sales for different product categories. 
We want to be able to type the product we’re interested 
in into cell A6, and then see the sales volume for that item 
in cell B6. Obviously, we can see that at a glance in this 
simple example, but the same idea applies to much bigger 
worksheets, and to looking up across different worksheets.

The text we’re searching for is in cell A6 and the data is in 
the range B1:D4. The first row must contain the data we’re 
searching for. The first row is number 1, so our data (for 
June) is in row 2. We use the match type of FALSE to ensure 
there is an exact match. A match type of TRUE would return 
the nearest lower value if there isn’t an exact match.

Here’s what our formula would look like:

=HLOOKUP(A6, B1:D4, 2, FALSE)
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41Finding data with MATCH

The VLOOKUP and HLOOKUP functions are fairly limited: you 
can only look up values to the right (VLOOKUP) or below 
(HLOOKUP) the data you search for, and you need to know 
the number of rows/columns away your desired data is. If 
you insert rows/columns, you can break the formula. That’s 
why it’s better to use a combination of the INDEX and 
MATCH functions.

The MATCH function is used to find the position of an item 
within a range of cells. It works like this:

=MATCH(data to match, range to find it in – must be a 
single row or column, type of match)

The type of match is optional. Use 0 to force an exact 
match. The default option (1) returns the largest value up 
to and including your data to match. Use -1 to find the 
smallest value equal to, or above, your data.

For example, let’s search for a food item in the spreadsheet 
below. We’ll put the item we want to find in cell A9. Our 
food items are in the range A2:A7. Here’s the formula:

=MATCH(A9, A2:A7, 0)

The returned value is 4, because “Lollies” is the 
fourth item in the range.
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42 Using the INDEX function

The INDEX function returns a particular data item, given its 
position in a range. The range must be in a single column or 
row. The function is structured like this:

=INDEX(range, item number)

For example, using our ice cream shop example (see Tip 
41), we can look up the second item in the sales list (range 
A2:A7) using:

=INDEX(A2:A7,2)

This returns the value “Double scoop” as you would expect.

The INDEX function is most powerful when combined with 
the MATCH function. You can replace the item number in 
the range with a MATCH function, which can generate an 
item number by searching in another range. Then, INDEX 
can be a flexible replacement for VLOOKUP and HLOOKUP. 

For example, to find the quantity of lollies sold, we’d use:

=INDEX(C2:C7, MATCH(“Lollies”, A2:A7, 0))

Here’s a ready reference for that combination:

=INDEX(range containing data to return, MATCH(data to 

search for, range to find it in, type of match))

You can use INDEX together with both a row number and a 
column number. The range doesn’t need to be a single row/
column when you do that:

=INDEX(A2:C7, row number, column number)

MATCH can replace both the row and column numbers. 
Here’s an example, which searches the rows for “Lollies” and 
the columns for “Price” and returns the number in that cell:

=INDEX(A3:C8, MATCH(“Lollies”,A2:A7,0), 
MATCH(“Price”,A1:C1,0))
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43Using the CHOOSE function

The CHOOSE function is used to select an item from a list 
of items provided in the function. You provide the position 
number of the item you want, followed by a list of the 
items. The items can be numbers, pieces of text, or ranges.

This is how you use the CHOOSE function:

=CHOOSE(item number you want, list of items separated 

by commas)

For example:

=CHOOSE(4, “Monday”, “Tuesday”, “Wednesday”, 
“Thursday”, “Friday”, “Saturday”, “Sunday”)

This would give you “Thursday”. 

You can use a cell reference in place of the item number:

=CHOOSE(A6, “Monday”, “Tuesday”, “Wednesday”, 
“Thursday”, “Friday”, “Saturday”, “Sunday”)

If you type 3 into cell A6, you’ll see “Wednesday” in the 
cell containing this CHOOSE function. If you don’t provide a 
valid item number, you’ll see an error message in the cell.

You can use CHOOSE to return a range, which can then be 
used in other functions. For example:

=SUM(CHOOSE(2, B2:B7, C2:C7, D2:D7))

Here, the CHOOSE function gives the range C2:C7 to the 
SUM function to add up.

If you want to select a random item, use the RANDBETWEEN 
function. It takes the lowest and highest numbers for your 
random number. Random numbers change whenever the 
spreadsheet is recalculated. Try this:

=CHOOSE(RANDBETWEEN(1,7), “Monday”, “Tuesday”, 
“Wednesday”, “Thursday”, “Friday”, “Saturday”, “Sunday”)
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44 Rounding data values

You can use the buttons in the 
Number group of the Home tab to 
increase or decrease the number of 
decimal places a cell shows. This 
doesn’t change the number, though, 
which can lead to odd results when 
you do sums with them. If you enter 
0.25 in two cells and format to one 
decimal place, they’ll be shown as 0.3. 
But they’ll still add up to 0.5.

To fix this anomaly, round the numbers themselves using the 
ROUND function. It works like this:

=ROUND(cell reference, number of decimal digits)

l1 Insert a new column (if necessary) beside your data.

l2 In a cell beside one of the figures you need to 
round, type in =ROUND(

l3 Select the cell containing the data to round.

l4 Enter a comma, followed by the number of 
decimal spaces you want to round to. For 
currencies, for example, enter 2.

l5 Press Enter to add a closing parenthesis.

l6 Your formula cell now contains the rounded 
value. Decimal digits of 5 or above are rounded 
up, and others are rounded down. You can 
copy the formula down to round other values in 
the column. Then, you can copy the cells with 
rounded numbers and paste their values over the 
unrounded data (see Tip 12).
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45Using advanced 
rounding functions

The ROUND function is great for most purposes, but there 
are additional functions that give you more control over how 
data is rounded:

• ROUNDUP(cell reference, number of decimal digits). 
This function always rounds numbers up. For example, 
ROUNDUP(2.111, 2) gives 2.12 and not 2.11. If you’re 
rounding negative numbers, it rounds them away from 
zero.

• ROUNDDOWN(cell reference, number of decimal 

digits). This function always rounds numbers down. 
For example, ROUNDDOWN(2.199, 2) gives 2.19 and 
not 2.2. If you’re rounding negative numbers, it rounds 
them towards zero.

• TRUNC(cell reference, number of decimal digits to 

keep). This function truncates (or shortens) the number 
by chopping off the decimal part. If you don’t tell it 
how many digits to leave, it removes all of the decimal 
portion. TRUNC(2.777, 1) gives you 2.7. TRUNC(2.777) 
gives you the whole number 2.

• MROUND(cell reference, multiple). This function is 
used to round to the nearest multiple of a number. For 
example, you could see which multiple of 10 is closest 
to a particular number. 22 would round to 20. 25 
would round to 30. 
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46 Calculating with dates

You might have noticed that dates turn into (usually quite 
big) numbers if you format a date as a number. 

That’s because Excel doesn’t store the date, month, and 
year of a date. Instead it records a date as the day number, 
counting from 1st January 1900. When Excel displays the 
date to you, it decodes it into the form you want to use. 

Because dates are stored as numbers, you can perform 
simple calculations on them:

• You can work out how many days there are between 
two dates by just subtracting the earlier date from the 
later date, as this example shows:  

There is also a function for this. DAYS(end date, start 

date) will count the days between two dates.

• You can add a number of days to a date. For example, 
if your invoice is due in 30 days, you can work out the 
due date by adding the number 30 to the date the 
invoice was issued.
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47Making dates 
and breaking them down

Excel provides several functions for date handling. They 
make it easy to split the date up into its constituent parts, 
and help you compile your own dates in the correct format:

• DAY(cell containing date). Extracts the day number 
from the date in the cell you give it.

• MONTH(cell containing date). Pulls out the month 
number from the date.

• YEAR(cell containing date). Extracts the year from the 
date in the cell.

• DATE(year, month, date). Creates a date in the correct 
Excel format, using the numbers you give it. Note that 
Excel cannot handle years before 1900. If you enter 
a lower number than 1900, it’ll be added to 1900 to 
make a year later than 1900.
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48 Creating custom date formats

You can create your own date formats. Click 
the cell(s) containing the dates you want to 
format, then click to expand the Number 
group of the Home ribbon. Use the small 
arrow beside where it says Number. To 
create your own date format, click Custom 
in the category list. In the Type box, enter the code for your 
custom format. The code is made up of these symbols:

• d. Days as numbers 1 to 31.

• dd. Days as numbers 01 to 31.

• ddd. Short day names: Sun, Mon, Tue, etc.

• dddd. Full day names: Sunday, Monday, Tuesday, etc.

• m. Months as numbers 1 to 12.

• mm. Months as numbers 01 to 12.

• mmm. Short month names: Jan, Feb, Mar, etc.

• mmmm. Full month names: January, February, etc.

• mmmmm. The first letter of the month: J, F, M, etc.

• yy. Year as two digits – e.g. 25 for 2025.

• yyyy. Full four-digit year.

For example, to get a date in the form of Friday, 31 Oct 25, 
you would use: dddd, dd mmm yy.
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49Using multiple lines 
of text in cells

Here are some tips for working with lengthy text that spans 
multiple lines within the cell.

l1 By default, text will spill out of the right of the 
cell and into other cells to the right of it. If data is 
entered into one of those other cells, it will cover 
your text, as shown here. 

To fix this, click the cell with the text in and then 
click the Wrap Text button on the ribbon. It’s in 
the Alignment group of the Home tab. (You can 
adjust the column width too – see Tip 4.)

l2 To enter a line break when you’re typing text into a 
cell, use Alt + Enter.

l3 To edit your text more easily, expand the formula 
bar. Click it and drag the bottom of it down.
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50 Cleaning your text

There are several functions you can use to clean your data 
to avoid unexpected outcomes later on, and to ensure your 
spreadsheet output looks right:

• TRIM(cell containing text). This function strips out 
all spaces at the start and end of text, and any extra 
spaces in the middle. Here’s an example of the output 
below, with the length shown so you can see where 
there are spaces at the end.

• CLEAN(cell containing text). This function strips out 
the first 32 non-printing characters in the character set, 
including line breaks. You’re only likely to need this if 
you’ve imported text from another computer system. If 
you see strange symbols in your data, this might help.

• PROPER(cell containing text). This function is used to 
capitalize the first letter of each word. It can clean up 
the formatting of names. It doesn’t accurately capitalize 
names with a capital mid-way through, though (such 
as McCartney).

• UPPER(cell containing text). This converts the text to 
capital letters. You could use it to standardize order 
codes, for example.

• LOWER(cell containing text). This function converts 
text to lower case.
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51Joining text 
from different cells

There are three ways you can join pieces of text:

• The & operator. Here’s an example, where I’ve made 
an email address by joining the first name, a dot, last 
name, and the “@example.com” part of the address. 
Some of the text is in the spreadsheet cells, and some 
of it is in the formula. When you put text in a formula, 
you put quotation marks around it, “like this”.

• CONCAT(text to join, text to join...). This is short for 
concatenate, which basically means to join things up. 
Before Excel 2016, this was called CONCATENATE.

• TEXTJOIN(text to add between joined text, ignore 

empty?, text to join, text to join...). This function was 
new in Excel 2016. It’s great for joining names because 
you can tell it to add a space between joined words, 
and to ignore empty cells. It works with a range too.
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52 Getting the 
length of a piece of text

In Excel (and many other computing arenas), a piece of 
text is called a string. It can be helpful to know the length 
of a string. For example, you might use a spreadsheet to 
organize social media content, and need to keep a close eye 
on character counts.

You can use the LEN function to count how many characters 
(including spaces) are in a piece of text.

l1 Enter the text you want to know the length of.

l2 In another cell where you would like to see the text 
length displayed, enter =LEN(

l3 Click the cell containing the content you want the 
length of.

l4 Type a closing parenthesis ). Now, if you wanted 
to see the length of the text in cell A1, your cell 
would contain =LEN(A1)

l5 Press Enter to see the length shown in your 
spreadsheet. The count includes any spaces in the 
string, even if they’re at the end of the text in 
the cell you’re counting. When the text in the cell 
changes, your text length will update automatically.
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53Searching in text

There are two Excel functions you can use to search inside 
the text in a cell: 

• The FIND function is case-sensitive, which means it 
treats capital and lower case letters as if they were 
different letters. If you look for a “k” in “Karen”, you 
won’t find it using FIND because the K in that string is 
capitalized. If you want an exact match, FIND is ideal.

• The SEARCH function is not case-sensitive, and it also 
enables you to use wildcards to search (see Tip 32). 
This is a more flexible option, and is the one you’ll 
want to use most of the time. The exception might 
be if you want to search your text for an asterisk or a 
question mark. SEARCH will treat them as wildcards 
instead of looking for them in the text, unless you use 
a tilde before the asterisk or question mark. It might be 
simpler to use FIND instead in that case.

The result is the first position number where your text was 
found in the cell you’re searching. The count starts at 1 for 
the first character in that cell. If the text you’re looking for 
is not found in the text you’re searching, you’ll get the error 
message #VALUE.

Both functions use a similar format:

=FIND(text to find, cell to search, starting position)

=SEARCH(text to find, cell to search, starting position)

Use the optional starting position if you don’t want to start 
looking from the beginning of the text you’re searching. For 
example:

=SEARCH(“hello”, A1, 5) 

searches cell A1 from the fifth character in that cell, for the 
text “hello” in any combination of upper or lower case.
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54 Extracting pieces of text

There are three functions you can use to extract pieces of 
text or parts of a number from a cell: 

• LEFT(cell containing text, number of letters). Extracts 
the first letters from a cell. If you don’t include the 
number of letters, the function gives you the first letter.

• RIGHT(cell containing text, number of letters). 
Extracts the final letters from a cell. If you don’t specify 
how many letters, the function gives you the last one.

• MID(cell containing text, start position, number of 

letters). Extracts some text from the middle of the cell.

For example, if cell A3 contains an order code and the first 
four letters indicate the product type, you could extract the 
product type using:

=LEFT(A3, 4)

Imagine you had a six-digit part number (e.g. 198542) in 
cell A23, where the middle two digits indicated the bin 
where they’re stored in the warehouse (see screenshot 
below). You could extract the bin number using:

=MID(A23,3,2)

This gives us two digits, starting with the third digit (85). 
Note that you can use MID with numbers, as well as text.
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55Splitting 
first and last names

You might have a spreadsheet where each person’s first 
and last name is combined in a single cell. You can use a 
combination of the LEFT, RIGHT, and FIND functions to split 
the names into separate cells. (See also Tip 3 & Tip 56.)

You use the FIND function to find the position of the space 
in the cell. You can then use that with the LEFT and RIGHT 
functions to pull out the first and last names.

To find the position of the space in cell A2, you would use:

=FIND(“ “, A2)

If the name is, for example, “George Harrison”, the space is 
in position 7. We only need the first six characters for the 
name, so when we put the FIND function in place of the 
number of letters we want to extract, we subtract 1:

=LEFT(A2, FIND(“ “, A2) - 1)

To work out how many letters to take from the right, we 
work out how long the whole name is and then subtract the 
position number of the space:

=RIGHT(A2, LEN(A2) - FIND(“ “, A2))
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56 Splitting text across columns

You can also split text (including first and last names) using 
the Text to Columns feature. This won’t update the names 
when the joined name changes, unlike a formula (see Tip 55).

l1 Select the cells containing the text to split.

l2 Click the Data tab, and choose Text to Columns.

l3 Choose “Delimited” if you want to separate text 
using spaces, commas, or other symbols. Choose 
“Fixed width” if you want to always have the same 
number of characters in each column. Click Next.

l4 When you 
choose 
“Delimited”, 
you can 
choose which 
symbols (or 
“delimiters”) 
are used 
to split the 
column. If 
you’re splitting 
names, choose Space as your delimiter. Click Next.

l5 Using “Fixed width”, you click 
and drag lines to show where 
to split the text. Click Next.

l6 You can (optionally) choose the 
data format to use for each 
column by clicking the column 
in the data preview, then 
choosing the data format above. Click Finish.
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57Replacing text in a cell

There are two functions you can use to replace text:

• SUBSTITUTE(cell containing text, characters you want 

to replace, new characters you want to use, which 

occurrence you want to replace). This will replace 
the characters you specify with new characters. If you 
miss out the last option, all of the occurrences will be 
replaced. This function is useful if you want to change 
words or phrases and you don’t know (or don’t mind) 
where they are in the cell. Here’s an example, where 
the function is used to replace the word “November” 
with “December” each time it occurs in the text:

• REPLACE(cell containing text, position number of 

first character you want to replace, number of 
characters you want to replace, new text). Use 
REPLACE to change specific characters in the cell. 
It might be useful if you have data such as order 
codes, which follow a particular pattern. The number 
of characters you replace and the number of new 
characters you introduce can be different. You can 
replace three characters with one character, for 
example. Here, I replace three characters (BCD) starting 
at position 2 (B), with the single character “X”:
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58 Counting the 
number of words in a cell

There isn’t a built-in function to count the number of words 
in a cell, so it requires a formula. The formula works by 
removing the spaces, and then seeing how much shorter the 
resulting text is. You’ll need the SUBSTITUTE (see Tip 57), 
LEN (see Tip 52) and TRIM (see Tip 50) functions. 

l1 Start by getting the length of the text where you 
want to count words. I’m using cell A1. To avoid 
errors, we’ll use TRIM to remove any extra spaces. 
Enter the following in the formula bar: 
=LEN(TRIM(A1))

l2 We’re going to remove the spaces in the cell. We 
use SUBSTITUTE to tell Excel to replace spaces with 
nothing, by using quotation marks with nothing 
between them for the replacement text. (The first 
quotation marks contain a space.) We then need to 
wrap all of that in a LEN function to work out how 
long the string is now, and we’re going to subtract 
that from the length of the original string. Add the 
new parts of your formula shown here: 
=LEN(TRIM(A1)) - LEN(SUBSTITUTE(A1,” “,””))

l3 Finally, we need to add 1 to make it accurate, 
because the last word doesn’t have a space after it. 
Your final formula is: 
=LEN(TRIM(A1)) - LEN(SUBSTITUTE(A1,” “,””)) + 1
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59Counting occurrences 
of a word or phrase

To count the number of times a particular word, phrase 
or character sequence appears in a piece of text you use a 
similar approach to that for getting a word count (see Tip 
58). You replace the text you are searching with nothing and 
work out how much shorter the text is now. That will tell 
you how many characters were removed, so you divide the 
result by the length of the text you’re looking for to work 
out how many occurrences there are of your text.

Take care with the parentheses in this formula!

l1 We’ll start our formula with an opening 
parenthesis, and then work out the length of the 
text we’re searching. My text is in cell A1. My 
formula begins like this: 
=(LEN(A1)

l2 Now, we’ll search for and remove the text we want 
to count, using SUBSTITUTE. I’m going to search 
for the letters “ab”. We’ll count how long the text 
is after we’ve done this, so we’ll wrap this in a LEN 
function. We’re going to subtract this from the 
original length of the text. We’re going to close the 
parenthesis we opened at the start of this formula 
here too. Add the new parts to your formula as 
shown here: 
=(LEN(A1) - LEN(SUBSTITUTE(A1,”ab”,””)))

l3 Finally, we need to divide the result by the length 
of the text we’re counting. Here’s the complete 
formula: 
=(LEN(A1) - LEN(SUBSTITUTE(A1,”ab”,””)))  
/ LEN(“ab”)
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60 Debugging: 
Tracing precedents

Excel has some features to help you remove errors from (or 
“debug”) formulas. By tracing precedents, you can quickly 
see where the data used in your formula comes from.

l1 Select the cell containing the formula that you wish 
to investigate.

l2 On the Formulas tab, click 
Trace Precedents in the 
Formula Auditing group. 
An arrow appears with 
dots on it, showing where 
the values come from that 
feed into your formula. 
In my example, it shows 
the two values used to 
calculate the profit. 

l3 Click Trace Precedents 
again, and you can dig 
deeper. In my example, 
it shows the values used 
to calculate the revenue 
and total cost, which are 
ultimately used to work 
out the profit. You can 
keep going deeper and 
deeper until you hear the 
error gong.

l4 Click Remove Arrows on 
the ribbon when you’ve 
finished.
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61Debugging: 
Tracing dependents

Excel also enables you to trace a cell to the formulas that 
rely on it, so you can track down any errors more easily.

l1 Select the cell containing the value that you wish 
to investigate. This cell can contain a formula or a 
number value. I’m tracing the sales volume (B3).

l2 On the Formulas tab of 
the ribbon, click Trace 
Dependents. You’ll find it 
in the Formula Auditing 
group. 

l3 Arrows extend from your 
chosen cell to those that 
use it in their formulas. In 
my example, you can see 
the sales number is used 
to work out the revenue 
and the total cost.

l4 You can click Trace 
Dependents again to see 
which cells use those 
results. In my example, 
it extends an arrow 
to the Profit box, so 
you can trace how the 
sales volume ultimately 
influences that figure (see 
bottom right).

l5 Click Remove Arrows on 
the ribbon when you’ve 
finished debugging.
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62 Debugging: 
Evaluating formulas

Excel can break a complex formula down and step you 
through it so you can understand the results you’re getting.

l1 Select the cell containing the formula.

l2 On the Formulas tab (Formula Auditing group), 
click Evaluate Formula. It’s just an icon on small 
screens.

l3 You see the formula for the cell you’re studying. 
You click Evaluate to expand the underlined part of 
the formula and show the number there.

l4 If a value comes from another formula, click Step 
In to see that formula and break it down. Use Step 
Out to go back up a level.
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63Using the Watch Window

You can use the Watch Window to keep an eye on 
important values, wherever you scroll the spreadsheet.

l1 On the Formulas tab of the ribbon, 
click Watch Window. It’s in the 
Formula Auditing group. 

l2 A new window opens that floats on 
top of your spreadsheet. If it’s in the 
way, you can click and drag it at the 
top to reposition it on your screen.

l3 Click the Add Watch button in this window.

l4 Select the cell you want to watch. You can use 
the Watch Window to watch cells on different 
worksheets and even in different open workbooks 
(Excel files).

l5 Now you can see that cell’s contents, even if 
they’re not currently visible in the spreadsheet. The 
Watch Window updates whenever the contents of 
those cells change in the spreadsheet.

l6 When you no longer need to watch a cell, select it 
in the Watch Window and click Delete Watch.



68

64 Adding simple 
conditional formatting

Conditional formatting changes the appearance of cells 
depending on their values. It helps you understand your 
data at a glance, by showing you whether values are high or 
low, compared to others in the same range.

l1 Select all the cells in the range you want to 
compare.

l2 On the Home tab, click Conditional Formatting in 
the Styles group.

l3 For simple conditional formats, choose Data Bars, 
Color Scales, or Icon Sets. They’re shown on 
this page, from top to bottom. You can choose 
different styles for each format. Data bars put a 
bar chart in each cell to show you how it compares 
to others. Color scales use color gradients, in my 
example going from red (low), through yellow to 
green (high). Icon sets divide the data up. In this 
three-icon set, for example, the top third of values 
have a green icon, the middle third yellow, and the 
bottom third red.
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65Adding advanced 
conditional formatting

You can also write your own rules for conditional formatting.

l1 Select all the cells you want to compare.

l2 On the Home tab, click Conditional Formatting. 
Choose Highlight Cells Rules (shown left, below) 
to compare with particular values, or Top/Bottom 
Rules to compare the data with itself (shown right, 
below). For example, under Top/Bottom Rules, 
you can highlight values that are above or below 
average, or the top or bottom 10 values.

l3 You can then enter a value (if appropriate), and 
choose which color to use.

l4 Click OK to apply your formatting.
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66 Creating new rules 
for conditional formatting

You can create your own rules for conditional formatting, 
using any formula. As an example, I’ll show you how to 
highlight text with more than four characters.

l1 Select the first cell that you want to apply this 
formatting to. I’ve selected cell A1.

l2 From the Conditional Formatting menu, choose 
New Rule. 

l3 Click “Use a formula...”.

l4 In the box 
provided, enter 
your formula. 
When the result 
of this formula 
is true, your cell 
will be formatted. 
Avoid using the 
cursor keys to edit 
your formula: they 
change the cell 
references instead. 
Use the reference of your cell where appropriate. 
For example, my formula is: 
=LEN(A1) > 4

l5 Click the Format button to choose the formatting 
to use when your formula is true.

l6 Click OK to apply your formatting.

l7 Use the Format Painter (see Tip 67) to copy the 
conditional formatting to other cells.
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67Managing 
conditional formatting

See how to delete, copy, and manage conditional formats:

l1 In the Conditional Formatting menu, use Clear 
Rules to remove the conditional formatting, while 
leaving other formatting on the cell intact.

l2 Use Manage Rules to see the rules in use. You can 
select a range first, or use the menu at the top to 
see all the rules that apply to the worksheet. Note 
that multiple rules can apply to the same cell. You 
could, for example, create two rules that highlight 
long text one color, and short text another color. 
When you select a rule, you can edit it or delete it 
using the buttons in this window.

l3 To copy conditional 
formatting (or any 
formatting, in fact), use 
the Format Painter. Click 
the cell containing the 
formatting and select 
the Format Painter in the 
Clipboard group of the Home tab. Then, select the 
cells you want to copy the formatting to.
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68 Visualizing your data

There are several useful ways to visualize data. They’re on 
the Insert tab.

l1 Select your data, including its column and row 
titles, and insert a bar chart or pie chart.

l2 If your data has a geographic element, you can 
insert a color-coded map (new in Excel 2019).

l3 Sparklines are graphs inside a cell. You can choose 
line or bar graphs. They show you trends, and you 
can highlight the high and low points in a different 
color using the Sparkline tab.
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69Using Quick  Analysis

Excel 2013 introduced Quick Analysis, which gives you rapid 
access to popular analysis features.

l1 Select your data.

l2 At the bottom right of your selection is the Quick 
Analysis menu. Click it to open it, or use Ctrl + Q. 
If you use the keyboard shortcut, you can simply 
click in your data first, without selecting it all.

l3 Choose one of the available formats to apply it in a 
single click. For example, you can choose from five 
conditional formatting options and several charts, 
and you can add totals, or insert sparklines.
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70 Using What-If? scenarios

You can model different possibilities using What-If? 
scenarios. They enable you to store several values for a cell 
and switch between them, so you can see the effect on your 
calculations. It’s simpler than retyping values into cells.

l1 Create your spreadsheet 
as usual. It’s a good idea 
to complete all the cells 
you’ll be using to test 
your formulas work.

l2 Select the cell(s) you 
want to model different 
scenarios for. I’ll select 
the unit cost and sale 
price cells, so I can see 
how the profit is affected 
by them changing.

l3 Click the Data tab on the ribbon. Click What-If 
Analysis, and open the Scenario Manager.

l4 Click the Add button. Give your scenario a 
descriptive name, and click OK.
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...cont’d

l5 Enter the values for the cells that you want to 
change for the scenario. In my case, I’m going to 
increase the cost for this scenario, but leave the 
price the same. 

l6 Click Add to add another scenario or OK if you’ve 
finished. You can add many scenarios. 

l7 To view a scenario, open the Scenario Manager. 
Select the scenario and then click Show. The cells 
are updated with the values for that scenario, 
and the formulas are recalculated. Use Edit in the 
Scenario Manager to add new cells to the scenario.

70
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71 Using data tables

Data tables show you the formula results from a range of 
inputs, so you can see them side by side. You might find it 
easiest to learn this by trying my example. I want to see how 
the profit varies with different sales volumes.

l1 Create your worksheet, including the formula for 
calculating your result. Then, add a column of 
input values you want to test. To the right and 
one cell above, add a cell reference to the result of 
your formula. See my example below, where I’m 
showing the formulas in the cells. (You can get this 
view using Ctrl + `, which is a grave accent, or by 
clicking Show Formulas in the Formula Auditing 
group of the Formulas tab.)

l2 Select the column of input 
values, and the formula 
reference, as shown on the 
right.

l3 Go to the Data tab, choose 
What-If Analysis, and select 
Data Table.
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l4 Click in the Column input cell box (because the 
inputs we want to test are organized in a column). 
Then, click the cell that shows where this input 
value belongs on the main part of your worksheet. 
For example, I’m modeling how the profit changes 
with different sales volumes. So I now select the 
cell that contains the sales volume. Click OK.

l5 Your data table is completed with the formula 
results for each of your inputs. Mine shows, for 
example, that a sales volume of 600 generates 
a profit of $1176. I can test this is correct by 
entering 600 in box B3 and seeing how that 
changes the profit shown on the left. You’ll need 
to format the new cell contents correctly.

...cont’d 71
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72 Modeling two 
formulas in a data table

You can also create a data table that shows the outcome for 
two formulas as one of the inputs changes.

l1 Create your worksheet, including the formulas for 
calculating your results. Then, add a column of 
input values you want to test. To the right and 
one cell above, add a cell reference to the result of 
your first formula. In the cell beside it, add a cell 
reference to your other formula.

l2 Select the column of 
input values, and the 
formula references, as 
shown on the right.

l3 Go to the Data tab, 
choose What-If 
Analysis, and select Data Table.

l4 Click in the Column input cell box. Then, click the 
cell that shows where your varying input value 
appears in the main part of your worksheet. For 
example, I chose the cell (B3) with my sales volume 
in. Click OK to see your results.
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73Using two-dimensional 
data tables

You can also use data tables to test the effect of changing 
two of the inputs. I’ll use the sales and profit example again.

l1 Enter your data for your calculation, as before. On 
the right, add a grid of values you want to test. 
I’m testing the sales price and the sales volume.

l2 Enter the reference to your formula result in the 
top-left corner of your cell. I put =B10 in cell E2.

l3 Select the data cells in 
your table.

l4 Go to the Data tab, 
choose What-If Analysis, 
and select Data Table.

l5 In the row input cell, 
enter the cell for your 
data along the top of your 
table (it’s in a row). Put 
the cell for your other data 
item in the other box. Click 
OK. My table shows the profit (from the formula in 
B10) for each price and volume combination.
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74 Using Goal Seek

If you know the result you want from a formula, but don’t 
know the numbers that will give you that result, Goal Seek 
can help. This feature can be used, for example, to work out 
the sales price required to achieve a specific profit.

l1 Create your spreadsheet as usual, including any 
formulas you will need. It’s a good idea to add 
data in the cells the formulas use to test your 
formulas work.

l2 Select the cell containing the formula that you 
want to find the input numbers for. I’m selecting 
the cell with my profit formula (see Tip 73).

l3 Click the Data tab on the ribbon. Click What-If 
Analysis, and choose Goal Seek. 

l4 The Goal Seek 
dialog opens. 
The first box 
should contain 
the reference to 
your formula cell 
– in my case, the 
profit calculation. 
The second box is 
for the target number for that formula. In the third 
box, tell Excel which cell to change to achieve that 
value. That’s my sales price in cell B4. 

l5 Click OK. The 
spreadsheet is 
updated with the 
answer.
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75Preparing 
data for a pivot table 

Pivot tables enable you to summarize and analyze your data, 
and can give you incredible insight. Using a pivot table, 
you can easily create totals, averages, and counts across a 
huge number of individual data items. You can improve the 
performance of your pivot table by cleaning your data first.

l1 Use standard descriptions for your data. If you 
spell a company name or product name in two 
different ways, they’ll be shown as separate items 
in the pivot table, instead of having their values 
combined. See Tips 7-9 for tips on data validation.

l2 Delete any blank columns or rows in your data set 
to ensure the data in your pivot table is complete, 
and does not include entries for (blank).

l3 Ensure your data has a single row containing 
meaningful titles for each column.

l4 For best results, organize your data so that each 
row represents a unique time period or data 
item. For example, each row might represent a 
single transaction, or a single month’s sales. If a 
row contains several data items (such as sales for 
different months in different columns), the pivot 
table will be less useful. Here’s an example of a 
good data set. Each row contains the details for 
a single transaction. You could have many more 
columns and rows.
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76 Creating a pivot table

Follow these steps to build a pivot table.

l1 Click to position your cursor inside the data you 
want to analyze. It doesn’t matter where in the 
data you position the cursor.

l2 Click the Insert tab, and click 
the PivotTable button. If you 
can’t see it because your 
screen isn’t wide enough, 
you’ll find it by clicking Tables 
on the Insert tab.

l3 In the options, you can change the table or range 
used. You can also choose to insert the pivot table 
into your existing worksheet, instead of putting 
it into a new worksheet. Usually, you’ll want to 
simply click OK without making any changes here. 
This will create a pivot table based on your island 
of data, in a new worksheet.
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...cont’d

l4 The pivot table fields are 
used to design the layout 
of your pivot table. The 
field names are the same 
as the column names 
above your data, but we 
use the word “fields” 
and not “columns” now 
because you can arrange 
this data however you 
like. Within the PivotTable 
Fields panel, you drag the 
fields from the list into 
one of the boxes below. 
The data item you want 
to total goes into the 
Values box. In my case, 
it’s the “Sale value” field. 
Drag another field, such 
as Customer name or Country, into the Rows box. 
The pivot table will give you a total for each of the 
fields (for example, for each country).

l5 To make a two-dimensional pivot table, drag 
another field into the Columns box. I dragged 
the Date field in and Excel automatically grouped 
transactions by month for me. It now shows me 
sales value by customer and month.
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77 Deeper analysis 
 with pivot tables

Why not add another dimension to your analysis?

l1 You can add another field to your column or row 
box. For example, I added the Country above the 
Date in the Columns box. That gave me the total 
sales for each country, and a + button on the 
pivot table to drill down into detail by month. If I 
had put the Date first, I’d see the sales by month, 
with a button to break them down by country.

l2 You can also add fields to the Filters box. When I 
put the Country into the Filters box (and remove 
it from the Columns box), the pivot table has a 
Country filter. When I view the UK, for example, I 
don’t see the non-UK companies any more, and I 
get a monthly total and grand total for the UK.
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78Using averages and counts 
in pivot tables

By default, your pivot table will give you totals, based on the 
fields you put into the Values box on the PivotTable Fields 
panel. You can change this to get different values.

l1 Add the fields you want 
to perform mathematical 
analysis on into the Values 
box. You can have more than 
one field here, or you could 
add the same field twice if 
you want to see both the 
total and the count of the 
sale, for example.

l2 Click the field name inside the Values box to open 
a menu. Click Value Field Settings.

l3 Choose how you want to summarize values. For 
example, you could use the Count option to give 
you an insight into the number of orders per 
month, or use the Average, Min, or Max functions 
to help you forecast future sales. Click OK.
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79 Calculating 
 percentages in pivot tables

You can not only change how the data in your pivot table 
is calculated (for example, as a sum, count, or average), but 
how it is displayed (for example, as a rank or percentage).

l1 Add the fields you want to perform mathematical 
analysis on into the Values box.

l2 Click the field name inside the Values box to open 
a menu. Click Value Field Settings.

l3 Choose how you wish to summarize values. Given 
that you will be comparing these numbers to 
others, the Sum and Count are probably the most 
meaningful options to use.

l4 Click the Show Values As tab. Click No Calculation 
to open the menu. Now you can choose from 
percentage calculations, based on the grand total, 
a column/row total, or relative to a base item such 
as another customer. You could also choose the 
difference from a base item, a running total, a 
rank, or an index (which shows how significant a 
value is in its row or column).
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80Using slicers

Slicers provide an easier way to filter your pivot table (or a 
regular table) than using filters. They give you single-click 
access to different views of your data, and make it easier to 
see what has been filtered out of your view.

l1 If you are using a pivot table, 
click in the pivot table and 
then click the PivotTable 
Analyze tab. In the Filter 
group, click Insert Slicer. If 
you are using a regular table, 
go to the Insert tab, then 
click Insert Slicer in the Filters group.

l2 Use the checkboxes to 
indicate which fields you’d 
like to create a slicer for (see 
screenshot, right).

l3 Click OK. You will now see a 
panel for each of the fields 
you selected (see bottom 
right). Each item in it is a 
button you can click 
to turn a filter on or 
off. Use the button 
in the top right of 
the slicer to clear its 
filters. Use the button 
beside that to toggle 
between enabling 
multiple selections, 
and only allowing 
one. Drag your slicers 
to wherever you 
want them on the 
worksheet.
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81 Creating a pivot chart

Pivot tables are great for summarizing and analyzing 
numerical data, but it can be hard to see the overall picture. 
A pivot chart adds a visual representation.

l1 Click anywhere in your pivot table.

l2 Click the PivotTable Analyze tab, 
and click PivotChart. You’ll find 
it in the Tools group.

l3 Use the menu to 
choose the chart 
you want to use. 
You can select a 
type of chart on 
the left, and a 
design for it at 
the top. When 
you’ve finished, 
click OK. 

l4 Your chart is inserted in your worksheet. You 
can use slicers to change its display, or the filters 
positioned around it.
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82Tracing totals back to data

To understand the values that make up a summary value in 
your pivot table, you can drill down to the data.

l1 You can use the expand and collapse buttons (+/-) 
on your pivot table to see more detail in your 
data. If you cannot see these buttons, you may be 
able to enable them by clicking your pivot table, 
then clicking Show +/- Buttons on the PivotTable 
Analyze tab.

l2 You can also double-click any value to see the 
data that makes it up. For example, you could 
click a sum in your pivot table to see the individual 
items that make up that sum. The data items are 
presented as a new table in a new worksheet.

l3 When you have 
finished analyzing 
that data, I 
recommend 
you delete the 
worksheet that 
was created to 
avoid too many 
building up. To 
delete a worksheet, 
right-click its tab 
at the bottom of 
the worksheet and 
choose Delete from 
the menu.
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83 Refreshing a pivot table

If you make changes to your data, you will need to refresh 
your pivot table to reflect those changes.

l1 Click your pivot table to show the PivotTable 
Analyze tab.

l2 On the PivotTable Analyze tab, 
find the Data group and click 
Refresh or use Alt + F5 as a 
shortcut. If you want to update 
all your pivot tables, you can 
open the Refresh menu and use 
the Refresh All option.

l3 If refreshing all tables takes too long, you can use 
the Cancel Refresh option in that menu to stop it.

l4 As a safety measure, you 
can set the pivot table to 
automatically update when the 
workbook is opened. To do 
this, click in your pivot table 
to show the PivotTable Analyze 
tab. On the left, 
find the PivotTable 
Options. (If your 
monitor isn’t 
wide enough to 
show them, click 
the PivotTable 
menu on the left 
to see them.) 
On the Data tab, 
select the box to 
refresh data when 
the file is opened.
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84Inserting a table

Excel tables (not the same as data tables – see Tip 71) help 
you manage your data consistently. To create a table, you 
click in your data, and then click Insert Table in the Tables 
group of the Insert tab (or use Ctrl + T). Here’s an example:

The advantages of tables include:

• Consistency. If you enter a formula in one cell, it will 
be copied into the others in that column. If you edit 
the formula, all the other cells will also update.

• Filtering. Filters (see Tip 22) are automatically added.

• Easier data entry. When you reach the end of a row, 
use Tab to start a new row. Cell formats and formulas 
are copied down. If you add data in a cell next to the 
table, the table extends to it automatically.

• Easier printing. You can print just the table.

• More readable formulas. For example, if I select a 
range for my SUM formula, Excel describes it using the 
table and column name rather than cell references: 
=SUM(Table1[Order value])

• Easier scrolling. When you scroll, the column headings 
remain in view.

• Easier analysis. You can use a slicer (see Tip 80).



92

85 Adding totals to a table

Using a table makes it easy to add totals and other 
calculations. Follow these steps.

l1 Click the Table Design tab on the ribbon. If you 
can’t see it, click in your table to show it.

l2 In the Table Style Options group, check (or tick) 
the box beside Total Row to add a total row to the 
bottom of your table. The last column is added up 
automatically for you.

l3 Click your total, and you can choose a different 
calculation. You can click one of the empty cells 
in the total row to add a sum, average, or other 
calculation for its column too. If you look at the 
cell formula that’s added for you, you’ll notice it is 
actually using the SUBTOTAL function, which can 
carry out all of these calculations. To change the 
calculation type, it’s easiest to use the menu again.
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86Formatting your table

Make your tables look great with Excel’s formatting options.

l1 Click the Table Design tab on the ribbon. If you 
can’t see it, you need to click your table first.

l2 In the Table Style Options, the Banded Rows 
option gives you horizontal stripes, the Banded 
Columns option gives you vertical stripes, and the 
First Column and Last Column options apply bold 
formatting to those columns when selected.

l3 To remove the filters at the top of your columns, 
uncheck the Filter Button box.

l4 To change the colors, choose a style from the Table 
Styles group of the Table Design tab. On smaller 
screens, you’ll need to open the Quick Styles menu. 
Themes are grouped as Light, Medium, or Dark. You 
can choose New Table Style to design your own.
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87 Setting (and clearing) 
 a Print Area

Sometimes you won’t want to print your whole spreadsheet. 
Defining a print area tells Excel which part of the sheet to 
print by default, without having to select it each time you 
print your work.

l1 Select the cells you want to include in the 
Print Area.

l2 On the Page Layout 
tab, click the Print 
Area drop-down 
and choose Set 
Print Area.

l3 You’ll see “Print_
Area” appear in the 
Name box, above 
cell A1. Selecting 
“Print_Area” in 
this drop-down at 
any time will show 
you the print area 
that’s currently 
defined.

l4	 Add to an existing print area by highlighting the 
new cells to add, and selecting “Add to Print Area” 
from the Print Area drop-down. The new range of 
cells doesn’t have to be adjacent to the existing.

l5	 Delete your print area by selecting “Clear Print 
Area” from the drop-down.

Want to start again with a new Print Area? No problem. 
Simply highlight a new set of cells and start again.
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88Printing to fit the page 
or across multiple pages

Worksheets can quickly expand in all directions, which is 
fine when you’re scrolling, but difficult if you want to print. 
Using Excel’s scaling options, you can quickly make your 
worksheet fit on exactly the right number of pages. You’ll 
find the options on the Page Layout tab.

• Use the Scale to Fit options to choose how many pages 
wide and/or tall you want your printed worksheet.

• Alternatively, use the Scale option to set the percentage 
size you want to print your worksheet at.

• Use the Orientation option to choose a landscape or 
portrait layout, depending on the shape of your data.

• For the complete Page Setup options, click the arrow in 
the bottom-right corner of the Page Setup group.

You might need to experiment, but here are some tips:

• To fit your whole print area onto a single page, scale 
both the width and height to 1 page.

• For a data set with a few columns and lots of rows, try 
printing it one page wide, but as many pages down 
as required. Select 1 page for the width, and leave 
the height set to Automatic. For a data set with many 
columns and few rows, try selecting 1 page for the 
height, and leave the width box set to Automatic.

• To repeat the column or row headings on each sheet, 
click Print Titles on the ribbon. Enter how many rows or 
columns to repeat.
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89 Adding a page header

Adding titles, page numbers, and other information to your  
printout can make it look great – and help you to keep track 
of which file it has come from.

l1 On the Insert tab, click on Header & Footer (in the 
Text group) to open the Header & Footer tab.

l2 The sheet will change to Page Layout view, and the 
header boxes will appear at the top of your page, 
representing the left, center, and right positions.

l3 Click Header on the ribbon to choose from the 
default headers. These can get you started quickly.

l4 To customize your header, click in the appropriate 
section, and use the Header & Footer elements on 
the ribbon to add new information fields.

l5 To change the style or formatting of your header, 
select the text and change it using the Font 
buttons on the Home tab.

Note: The Header & Footer tab isn’t available if you’re using  
Freeze Panes. You’ll be sent instead to the Page Setup dialog 
box, which has all the same options, in a similar layout.
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90Adding a watermark

Unlike other Office programs, Excel doesn’t come with a 
watermark function, but you can add text or a background 
image, like a logo, which will appear onscreen and in print.

l1 Add an image to your document header and it will 
appear on every page. On the Insert tab, click on 
Header & Footer in the text group. Click the Picture 
button, browse to your image, and insert it. 

l2 &[Picture] appears in the header, and your logo 
appears on the sheet.

l3 Use the Format Picture button on the Header & 
Footer tab to crop or change the size of the image, 
convert it to grayscale or a washout, and more.

l4 When you’ve finished editing the header, click your 
data (outside the header), then click the View tab 
and choose Normal.
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91 Choosing cells 
to leave unlocked

You can protect your spreadsheet to prevent others editing 
it, or to avoid the risk of accidental overwriting.

If you want to allow some cells to be edited, you need to 
unlock those cells first. This could be useful if you wanted a 
user to be able to enter data, but not disturb formulas, for 
example. If you’re happy for the whole spreadsheet to be 
locked or unlocked, you don’t need to follow this process.

l1 Select the cells you wish to leave unlocked.

l2 Right-click in your selected cells. 
From the menu that opens, 
choose Format Cells.... You’ll 
find it near the bottom.

l3 Click the Protection tab.

l4 Unselect the Locked option. (All cells are set to be 
locked when you start a spreadsheet.)

l5 Your cells and spreadsheet are not actually 
protected from changes until you protect the 
worksheet (see Tip 94).
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92Hiding formulas in cells

You can protect the formula in a cell, so that it cannot be 
seen when the worksheet is protected. The result can still 
be seen on the worksheet, but the formula that generates 
that number cannot be seen in the formula bar. This process 
is similar to the one used for marking cells to be locked or 
unlocked for editing (see Tip 91).

l1 Select the cells containing the formulas you wish to 
hide. They don’t need to be next to each other.

l2 Right-click in your selected cells. 
From the menu that opens, 
choose Format Cells....

l3 Click the Protection tab.

l4 Select the Hidden option. When you start a new 
worksheet, no cells are set to be hidden so even 
if the spreadsheet is locked and cannot be edited, 
the formulas can be seen. You may also wish to 
lock the cells to stop them being edited.

l5 As with locking cells (see Tip 91), nothing 
actually changes until you protect the worksheet 
(see Tip 94).
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93 Password protecting ranges

If you’re sharing a workbook, you might want to allow 
different people to edit different parts of it, but be certain 
that they don’t accidentally overwrite other cells. You can do 
this by setting passwords for particular ranges. 

l1 Select the cells you want to password protect.

l2 Click the Review tab on the ribbon.

l3 Click Allow Edit Ranges in the Protect 
group on the ribbon.

l4 An options box opens, with buttons to 
modify or delete protected ranges. Click 
the New button to create a new one.

l5 Enter a title for the range. I use the name of the 
person who’s allowed to edit it. The range should 
be selected already, but you can edit it. Enter the 
password and click OK, and then confirm it.

l6 Click OK. Now you have told Excel which ranges 
to protect with which passwords, you need to 
protect the worksheet to turn the protection on 
(see Tip 94).
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94

As you’ve seen in the last three Tips, you can protect a 
worksheet to stop people from editing the cell contents, or 
viewing the formulas behind the results. Let’s see how you 
switch the protection on and off.

l1 Click the Review tab.

l2 Click Protect Sheet. It’s in the Protect 
group on the ribbon. 

l3 Enter a 
password that 
will be used to 
unprotect the 
sheet. If you 
don’t enter a 
password, then 
someone can 
simply click the 
Unprotect Sheet 
button to 
unlock it.

l4 Select the activities you’d like users to be able to 
undertake on cells that are not locked. You need to 
have unlocked these cells first (see Tip 91). You can 
let users sort or delete columns, for example.

l5 Click OK. Enter your password and click OK to 
confirm. Your worksheet is now protected.

l6 To unprotect your worksheet, click the Unprotect 
Sheet button in the Protect group of the Review 
tab of the ribbon.

Protecting the worksheet
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95 Protecting the workbook

As you’ve seen, you can prevent users from changing 
the data within a worksheet (see Tip 94). However, they 
could still delete the entire worksheet! To prevent users 
from deleting worksheets, adding new ones, or hiding or 
unhiding them, you need to protect the workbook.

l1 Click the Review tab.

l2 Click Protect Workbook. It’s in the 
Protect group on the ribbon. 

l3 Enter a 
password. 
The password 
is optional. 
If you’re just 
protecting the 
workbook (or a 
worksheet) to 
stop yourself 
accidentally overwriting things, you may prefer not 
to provide a password. Although the protection 
tools for worksheets and workbooks are not robust 
security features, Microsoft cannot help you recover 
a forgotten password.

l4 To confirm the 
workbook is protected, 
right-click a worksheet’s 
tab at the bottom to see 
whether the options to 
hide, delete, or rename 
the worksheet are 
available. They should 
be grayed out.
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96Protecting Excel files

There are several options you can use to protect your Excel 
file, containing all of its worksheets, from changes.

l1 Click the File tab above the ribbon and click Info in 
the menu on the left.

l2 Click Protect Workbook to see the options for 
protecting the file.

l3 Choose Always Open Read-Only to make Excel ask 
users whether they need to modify the file when 
they open it. This can prevent accidental changes 
being saved.

l4 Choose Encrypt with Password to password protect 
the file. Excel won’t open the file unless the correct 
password is entered. Don’t lose the password!

l5 Choose Mark as Final if the document is complete. 
Users will be warned you’ve marked it as final, and 
will have to click Edit Anyway to make changes.
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97 Data entry shortcuts

• Autocomplete function name. Tab

• Copy. Ctrl + C

• Copy formula, number, or text from cell above. Ctrl 
+ ‘ (apostrophe)

• Copy value from cell above. Shift + Ctrl + “

• Cut. Ctrl + X

• Cycle through absolute/relative cell references for 
selected cell in formula. F4

• Data Validation. Alt + D L

• Date, enter today’s. Ctrl + ;

• Delete cells. Ctrl + minus (-)

• Delete column. Alt + H D C

• Delete row. Alt + H D R

• Edit text or formula in a cell. F2

• Enter data and go to next cell on the right. Tab or 
Right arrow

• Enter data and keep the same cell active. Ctrl + 
Enter

• Enter data and move to next selected cell. Enter

• Enter data and move up a cell. Shift + Enter

• Enter the same data in all selected cells. Ctrl + Enter

• Fill down, copying top selected cell into selected 

cells below. Ctrl + D
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...cont’d

• Fill right, copying leftmost selected cell into selected 
cells. Ctrl + R

• Formulas, get placeholders after Excel recognizes the 
function you’re entering. Shift + Ctrl + A

• Formulas, insert name. F3

• Formulas, show/hide in cell. Ctrl + ` (grave accent)

• Insert cells. Ctrl + plus (+). Add Shift if required.

• Link, insert. Ctrl + K

• Open cell’s data validation choices or copy text from 
any cell above. Alt + Down arrow

• Paste. Ctrl + V

• Paste formats only. Ctrl + Alt + V T Enter

• Paste formula only. Ctrl + Alt + V F Enter

• Paste once only. Enter

• Paste Special. Ctrl + Alt + V

• Paste values only. Ctrl + Alt + V V Enter

• Refresh. Alt + F5

• Start a new line in the same cell. Alt + Enter

• Sum formula for cells above or to the left. Alt + =

• Undo. Ctrl + Z
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Formatting shortcuts

• Bold. Ctrl + B

• Borders, adding/removing. Alt + H B

• Borders, add around selected cells. Shift + Ctrl + &

• Borders, take off cells. Shift + Ctrl + Underline (_)

• Center cell contents. Alt + H A C

• Color, choose cell color. Alt + H H

• Currency format. Shift + Ctrl + $

• Date format. Ctrl + # (+ Shift on some keyboards)

• Format cells options. Ctrl + 1

• General number format. Shift + Ctrl + tilde (~)

• Hide. Ctrl + 0 to hide column. Ctrl + 9 to hide row.

• Insert table. Ctrl + T

• Italics. Ctrl + I

• Number (x,xxx.xx) format. Ctrl + Shift + !

• Percentage (x.xx%) format. Shift + Ctrl + %

• Strikethrough (crossed out). Ctrl + 5

• Time format. Shift + Ctrl + @

• Underline. Ctrl + U

• Unhide column. Alt + H O U L (Shift + Ctrl + 0 might 
work depending on your operating system)

• Unhide row. Shift + Ctrl + 9
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Navigation shortcuts

• Cancel a data entry, edit or menu selection. Esc

• Formula bar, expand or collapse. Ctrl + Shift + U

• Go one screen down or up. Pg Down / Up

• Go one screen left or right. Alt + Pg Up / Down

• Go to bottom right of data. Ctrl + End

• Go to cell reference or name. Ctrl + G

• Go to end of cell content in formula bar. Ctrl + End

• Go to next unlocked cell in protected worksheet. Tab

• Go to next/previous worksheet. Ctrl + Pg Down / Up

• Go to previous cell or previous option. Shift + Tab

• Go to start of row. Home

• Go to top left (A1). Ctrl + Home

• Move to edge of current data block or move to next 

data block from edge of current one. Ctrl + Arrow 
key

• Quick Analysis options (see Tip 69). Ctrl + Q

• Repeat the last action. Ctrl + Y

• Right-click menu (context menu). Shift + F10, or 
Context key.

• Search. Alt + Q. Use this to find an Excel feature by 
keyword. Use Ctrl + F to find/replace in spreadsheet.
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Selection shortcuts

• Select multiple rows/columns/cells. Ctrl + click

• Select to the clicked cell/row/column. Shift + click

• Select all. Ctrl + A

• Select column. Ctrl + Space

• Select row. Shift + Space

• Select current block of data. Ctrl + Shift + Space

• Select range with arrow keys (on/off for extend 
mode). F8

• Expand selected cells to bottom right of data. Ctrl + 
Shift + End

• Extend selected range by one cell. Shift + Arrow key

• Extend selected range to disconnected cells using 
Arrow keys. Shift + F8

• Extend selected range to edge of data, edge of 
sheet, or next nonblank cell. Ctrl + Shift + Arrow key

• Extend selection to top left (A1). Shift + Ctrl + Home

• Select precedent cells (see Tip 60). Ctrl + [

• Select dependent cells (see Tip 61). Ctrl + ]
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