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If you’re just starting out 
with Excel, please refer 
to our companion book 
Microsoft Excel in easy 
steps.

Introducing Excel VBA
Visual Basic for Applications (VBA) is the programming language 
that is built into the Excel spreadsheet application and other 
Microsoft Office applications. It extends Excel so it can perform 
tasks that can’t be done with standard Excel tools, and provides 
the capability to automate many routine tasks.

�e examples in this book assume the reader is an experienced 
Excel user who can accomplish these fundamental operations:

• Create workbooks and insert worksheets

• Navigate around a workbook and worksheet

• Use the Excel Ribbon interface

• Name cells and ranges

• Use the Excel worksheet functions

All examples are demonstrated using Excel in Microsoft 365, 
although most examples are applicable to earlier versions of Excel.

Enabling VBA
Before you can get started using the capabilities of VBA, it must 
first be enabled in your Excel installation:

l1 Launch Excel, then choose to open a Blank workbook

l2 When the workbook opens, 
choose the File item on the 
Excel Ribbon

All the examples in this 
book are available for 
free download at  
www.ineasysteps.com/
downloads/
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...cont’d

l3 Next, select the Options item – to 
open the “Excel Options” dialog box

l4 In the Excel Options dialog, choose 
the Customize Ribbon item on the 
left-hand pane

l5 Now, check the Developer option box in the right- 
hand pane

l6 Click the OK button to apply the change and to close 
the Excel Options dialog box

l7 See that a Developer tab has been added to the Ribbon

l8 Choose the Developer tab to see a Visual Basic button in 
the Ribbon’s “Code” group – VBA is now enabled

You can also open the 
Excel Options dialog box 
by pressing the Alt + F 
+ T keys.

In the Excel Options 
dialog you can click 
the + button beside 
the Developer item 
to reveal the groups it 
contains. If you right-
click on any group, a 
context menu offers you 
options to modify the 
groups that will appear 
on the Developer tab.
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A macro is a set 
of programming 
instructions stored in 
VBA code.

Recording a macro
Having enabled VBA, as described on pages 8-9, you can create a 
simple app by recording a “macro” to store actions:

l1 Open a blank workbook in Excel, 
then select worksheet cell A1

l2 On the Developer tab, click 
the Record Macro button in 
the Code group to launch the 
“Record Macro” dialog box

l3 Type a name of your choice in the dialog’s Macro name 
field – for example, type “BookTitle”

l4 Next, type a letter in 
the dialog’s Shortcut 
key field – for 
example, type “T”, to 
create a Ctrl + Shift 
+ T shortcut

l5 Now, choose to 
store the macro 
in �is Workbook

l6 Click the OK button to close the Record Macro dialog, 
and to begin recording actions

l7 Type the title of this book into previously selected cell 
A1, then hit Enter – to enter the title text into the cell

In the Record Macro 
dialog you can add a 
Description of what the 
macro will perform.
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The Record Macro 
button changes to 
Stop Recording when 
recording is taking place.

...cont’d

l8 Notice that focus has 
moved, so cell A2 is now 
automatically selected after 
you hit the Enter key

l9 Now, click the Stop 
Recording button in the 
Code group on the Developer tab – to stop recording 
your actions

l10 Click the Macros button in 
the Code group to launch 
the “Macro” dialog box and 
choose to see macros in 
�is Workbook

l11 Select the 
“BookTitle” 
macro, then click 
the Run button 
to execute the 
macro and see 
the book title 
text appear in 
the automatically 
selected cell A2

You can also use the 
shortcut keys Alt + 
F8 to open the Macro 
dialog box at any time.
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You can also use the 
shortcut keys Alt + F11 
to open the Visual Basic 
Editor at any time.

The Project Explorer 
window may already be 
visible when the Visual 
Basic Editor opens, and 
the project may already 
be expanded, but it 
is useful to practice 
opening and closing 
these items to become 
familiar with the Visual 
Basic Editor interface.

Viewing macro code
Having created a macro, as described on pages 10-11, the VBA 
programming instructions that were written when the macro was 
created can be viewed in the Visual Basic Editor:

l1 On Excel’s Developer tab, click the Visual Basic button 
in the Code group – to launch the Visual Basic Editor

l2 In the Visual Basic Editor, select View, Project Explorer 
– to open the “Project Explorer” window

l3 In Project Explorer, click the 
+ button beside the Book1 
project to expand its contents
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...cont’d

Code analysis

• Sub BookTitle ( ) – �is declares the beginning of a 
“subroutine” (Sub) with the same name you gave to the macro 
(BookTitle) and was written when it began recording.

• ‘ BookTitle Macro – �is is a comment, confirming that this 
subroutine is for a macro of your chosen name.

• ‘ Keyboard Shortcut: Ctrl+Shift+T – �is is another comment, 
describing the shortcut keys you chose to run this macro.

• ActiveCell.FormulaR1C1 = “Excel VBA in easy steps” – �is is 
an instruction that was written when you typed the book title 
into the cell and hit the Enter key.

• Range(“A2”).Select – �is is an instruction that was written as 
focus moved to cell A2 after you hit the Enter key.

• End Sub – �is denotes the end of this macro subroutine, and 
was written when you stopped recording.

�e color used in the code is the default syntax highlighting that 
the Visual Basic Editor automatically applies for easier reading. 
Blue is applied to “keywords” that have special meaning in Visual 
Basic code, and green is applied to comments describing the code. 
For clarity, the same color syntax highlighting is also used in the 
example code listed in the steps provided throughout this book.

l4 Now, in Project Explorer, double-click the Module1 node 
within the “Modules” folder – to see the macro VBA code

The ( ) parentheses that 
appear in the first line 
of code can contain a 
parameter list. This is 
demonstrated later, on 
page 90.

All lines that begin with 
an apostrophe are simply 
ignored when the macro 
is executed.
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If you try to specify 
a shortcut key that is 
already designated for 
use by another macro 
in the same workbook, 
a dialog will appear 
requesting you to specify 
an alternative shortcut 
key – so you cannot 
accidentally duplicate.

Testing a macro
Before starting to record the macro, as described on page 10, 
shortcut keys were specified in the Record Macro dialog and these  
can now be tested to ensure they can run the macro:

l1 With the Visual Basic Editor open, select View, 
Microsoft Excel, or click the  button on the toolbar to 
return to the Excel interface

l2 Next, select empty cell A3You can use the shortcut 
keys Alt + F11 to close 
the Visual Basic Editor.

l3 Now, press the Ctrl + Shift + T shortcut keys to test run 
the macro – the book title should appear in the cell you 
selected and the focus returned to cell A2 as instructed 
in code

It is important to remember that cell A1 was selected before the 
macro recording began, otherwise the action of selecting that cell 
would be written as an instruction in the macro. �is would mean 
the book title could only be written into cell A1 each time the 
macro was run.
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Although the lines of 
VBA code are executed 
from top to bottom, their 
order is unimportant in 
this macro – the cell’s 
styling can be set before 
or after its content is 
added.

Editing macro code
Now you are sure the macro can be run by both the Run button 
in the Macro dialog, and by the Ctrl + Shift + T shortcut keys 
you specified, but you probably will not need it to return focus 
to cell A2 after each run. �e code can be edited to remove the 
instruction to return focus, and also to style the text it writes:

l1 On Excel’s Developer tab, click the Visual Basic button 
in the Code group to launch the Visual Basic Editor

l2 In Project Explorer, double-click the project’s Module1 
item to see the macro VBA code

l3 Next, delete this instruction line that returns focus 
Range( “A2” ).Select

l4 Now, add these instructions anywhere within the 
subroutine to style the text in bold red 
ActiveCell.Font.Bold = True 
ActiveCell.Font.Color = vbRed

l5 Click 
the  
Save 
button

l6 Return to Excel and select any cell – press the Ctrl + 
Shift + T shortcut keys to run this edited macro

As you type instructions 
a pop-up box will often 
appear when you type a 
period/full stop, to offer 
a list of suggestions from 
which you can choose 
an item.

The eight Visual Basic 
color constants are 
vbRed, vbGreen, vbBlue, 
vbYellow, vbMagenta, 
vbCyan, vbBlack, and 
vbWhite – see pages 
52-53 for more on 
constants.
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Shortcut keys might also 
be specified to run these 
macros – for example,  
Ctrl + Shift + A  
(Absolute) and  
Ctrl + Shift + R 
(Relative).

Referencing relatives
Excel has two macro recording modes that differ in the way they 
refer to cells on the worksheet. �e default recording mode, used 
in the previous examples, refers to cells by their “absolute” position 
on the worksheet – cell A1, A2, A3, and so on. �e alternative 
recording mode refers to cell locations by their position on the 
worksheet “relative” to other cells – offset by a specified number 
of rows and columns from another cell. �e difference between 
the two recording modes is important, as macros that use absolute 
referencing always reference the same cell locations regardless 
of the currently selected cell, whereas macros that use relative 
referencing reference cells at locations offset from the selected cell:

l1 Clear all worksheet cells, then select cell A1 and begin a 
macro named “AbsoluteBookTitle”

l2 Type this 
book’s topic, 
then select cell 
B2 and type 
this book’s 
series name

l3 Hit Enter, 
then click Stop 
Recording

l4 Clear all 
worksheet 
cells, then 
select cell A1 
and click the 
Use Relative 
References 
button in the 
Code group

l5 Begin a macro named “RelativeBookTitle”, then repeat 
Steps 2 and 3 to complete the macro

Macros recorded using 
relative referencing are 
often more flexible, as 
they can be applied 
anywhere in a workbook.
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Empty comment lines 
are removed from this 
screenshot to save space.

...cont’d

l6 Click the Visual Basic button to open the Visual Basic 
Editor, then compare the VBA code of each macro

When selecting cell B2, absolute referencing refers to it by name, 
but relative referencing refers to it as offset by 1 row and 1 
column from the initially selected cell. To compare performance:

l7 Clear all cells, then select cell A2 and run the macro 
named “AbsoluteBookTitle”

l8 Again, clear all cells, then once more select cell A2 and 
run the macro named “RelativeBookTitle”

In this example, the 
macro using absolute 
referencing writes the 
book series name in the 
cell named B2, whereas 
the macro using relative 
referencing writes the 
book series name in cell 
B3 – as it is offset by 1 
row and 1 column from 
the initially selected cell.
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Click the  button to 
reveal a drop-down list 
of file types from which 
to choose.

Choose a folder location 
where you want to save 
workbooks. Here, it’s 
a folder named “Excel 
Workbooks” within the 
system’s Documents 
folder.

Saving macros
Since Excel 2007, workbook files have had the standard file 
extension of “.xlsx”, but these cannot contain Visual Basic 
macros. In order to save an Excel workbook and its macros, it 
must instead be saved as an Excel Macro-Enabled Workbook 
that is given a file extension of “.xlsm”. If you save a workbook 
containing a macro as a standard “.xlsx” file, all macro code will be 
lost – but Excel will warn you before this happens:

l1 In Excel, select File, Save As, then type “BookTitle” as 
the workbook name and click the Save button

l2 If the workbook contains a macro, a warning dialog will 
appear asking if you wish to proceed – unless you want to 
save the workbook without its macro, click the No button

l3 Change the file type to Excel Macro-Enabled Workbook, 
then click the Save button to save the complete workbook
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...cont’d

Although most macros are intended for use in a specific 
workbook, general-purpose macros that may be useful in many 
workbooks can be saved in the special Personal Macro Workbook. 
�is is a file named “personal.xlsb” that automatically opens in the 
background when Excel starts up – so the macros it contains are 
available to any other workbook. To save a macro in the Personal 
Macro Workbook, simply choose that option in the Record Macro 
dialog before you begin recording a macro:

l1 Click the Record 
Macro button 
and call the macro 
“Name”, then choose 
the Personal Macro 
Workbook option

l2 Type your name 
into the selected 
cell, then select Stop 
Recording and close Excel

l3 A dialog will appear 
asking if you wish to 
save changes made to 
the Personal Macro 
Workbook – click the 
Save button to retain the macro

l4 Next, start Excel 
and begin a new 
Blank workbook, 
then click the 
Macros button in 
the Code group

l5 Now, choose the 
saved “Name” 
macro and click 
Run to write your 
name into a cell

The Personal Macro 
Workbook runs in a 
hidden window that you 
can reveal by selecting 
the View tab, then 
choosing Unhide in the 
Window group. 
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Macros have been used 
to distribute malware 
– be wary of enabling 
macros in a workbook 
from an unknown 
source.

Trusting macros
Excel Workbook files (.xlsx) are regarded as safe, as they merely 
contain data, whereas Excel Macro-Enabled Workbook files 
(.xlsm) may pose a potential threat, as they are executable. 
Recognizing this, Excel automatically disables the macros in an 
Excel Macro-Enabled Workbook until the user consents to trust 
their safety. On opening a workbook that contains macros, a 
security warning offers the user the option to enable macros. If 
the user consents to enable macros, the workbook is regarded as 
trustworthy and the security warning will never appear again.

As an alternative to enabling macros in individual workbooks, a 
folder can be nominated as a trusted location. �is then allows 
Excel Macro-Enabled Workbook files to be placed inside that 
folder and run without security restrictions:

l1 Navigate to the folder containing an Excel Macro-
Enabled Workbook, and open it in Excel

l2 Click the Enable Content button if you consent to 
permanently enable macros in this workbook

Both .xlsx and .xlsm file 
types store workbook 
data in XML format. 
Excel also supports 
.xlsb files that store 
workbook data in binary 
format. This is favored 
by some users, but 
workbook content is 
more accessible to other 
software when stored as 
XML data.
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You can also use 
Trusted Documents to 
nominate a workbook 
so it will run without 
security restrictions.

All workbooks in 
Trusted Locations will 
run without security 
restrictions.

...cont’d

l3 Next, click the Macro 
Security button in the 
Code group to open the 
“Trust Center” dialog box

l4 In the Trust Center dialog, select the 
Trusted Locations item in the left-
hand panel

l5 Now, click the Add new 
location... button to open 
the “Microsoft Office 
Trusted Location” dialog

l6 Browse to 
select the 
folder you 
wish to 
nominate 
as a trusted 
location 
for Excel 
Macro-
Enabled 
Workbooks

l7 Click the OK button to see your nominated folder added 
to the list of Trusted Locations in the Trust Center
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Summary

• VBA (Visual Basic for Applications) is the programming 
language built into Excel that extends its capabilities beyond 
the standard Excel tools.

• �e Excel Developer option enables VBA and adds a 
Developer tab to the Excel Ribbon.

• �e Code group on the Developer tab contains a Record 
Macro button with which to create VBA macros.

• �e Macros button in the Code group lists available macros.

• �e Visual Basic button in the Code group opens the Visual 
Basic Editor to inspect macro programming instructions.

• Macro subroutines are stored in a project’s Module1 node.

• Subroutines contain programming instructions and comments.

• Specified shortcut keys, or the Run button in the Macro 
dialog, can be used to run a macro.

• Recorded macro programming instructions can be edited in 
the Visual Basic Editor to change the macro’s behavior.

• Excel’s default macro recording mode references cells by their 
absolute position.

• �e Use Relative References button in the Code group 
enables Excel’s alternative macro recording mode, which 
references cells by their relative position.

• A workbook that contains macro code must be saved as an 
Excel Macro-Enabled Workbook and “.xlsm” file extension.

• General-purpose macros can be saved in the Personal Macro 
Workbook so they are available in other workbooks.

• Excel automatically disables macros in an Excel Macro-
Enabled Workbook until the user consents to trust them.

• A folder can be nominated as a trusted location where Excel 
Macro-Enabled Workbooks can be placed and run without 
security restrictions.
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